View Issue Details

IDProjectCategoryView StatusLast Update
0001303SUMoBugpublic2010-12-22 22:48
Reporterwar59312Assigned ToKyle_Katarn 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWin32OSWindowsOS Version7 x64
Product Version2.10.4 
Target VersionFixed in Version2.10.6 
Summary0001303: Normal Window State - Size And Location Resets To Defaults After Maximizing Window
DescriptionAfter this bug was fixed: http://kcsofts.dyndns.org/mantis/view.php?id=1294

Now when Sumo is maximized it remembers that state correctly.

But the next time you run Sumo and un-maximize its window the normal window state, its size and location on screen when not maximized was forgotten. :(

It should be remembered from the last run.
Steps To Reproduce1.) Run Sumo and re-size its window to your liking. Move it where you want it too.

Now maximize Sumo and then completely close Sumo.

2.) Run Sumo again and it should still be maximized. Since was was maximized via the last run.

Now un-maximize the window. Notice the size and location of the window has been reset to defaults. :(

So the size and location you had previously set in step 1 was completely forgotten. :(

Sumo should always remember its window state (size, location, maximized or not).
Additional InformationSee bug http://kcsofts.dyndns.org/mantis/view.php?id=1294
TagsNo tags attached.

Activities

war59312

2010-12-07 03:18

reporter   ~0000623

Still does not seem fixed. :(

Tested on Windows 7. Still same odd behavior with v2.10.5.102.

Kyle_Katarn

2010-12-07 20:58

administrator   ~0000624

Does the problem occurs with this precise procedure ?
Unable to reproduce here (fix is efficient).
If you confirm the procedure, i'll send you an instrumented experimental test version.

war59312

2010-12-07 21:24

reporter   ~0000625

Yeah still happening.. To be clear..

1.) Run Sumo and change size and location to your liking. And then close and restart.

The location of the window is correctly remembered, but not its size.

2.) Now maximize the window. Close and restart.

The maximized state was remembered correctly. :)

Now un-maximize the window. It goes back to the correct location but not the correct size.

3.) Now lets close Sumo and restart it and try something different.

Move sumo window and resize to your liking. Then maximize the window.

Now close and restart sumo. Again it correctly remembered the maxmize state but now unmaximize the window again.

It is NOT at the correct location. Instead it is has the location that it was the last time before you and closed Sumo.

Hope that helps?

Kyle_Katarn

2010-12-22 10:41

administrator   ~0000626

Thanks, this helped me finding what was the trick !

war59312

2010-12-22 21:03

reporter   ~0000627

Indeed, fix confirmed. :)

Perfect now, thanks a lot!! :D

Kyle_Katarn

2010-12-22 22:44

administrator   ~0000628

Then, do you have re-opened the issue by mistake ? May i close it ?

war59312

2010-12-22 22:46

reporter   ~0000629

Hey,

Yeah, whoops. I thought I was only leaving a comment, but yea now I see it reopened it. Sorry.

Thanks for fixing again..

Happy holidays,

Will

Issue History

Date Modified Username Field Change
2010-11-09 20:19 war59312 New Issue
2010-11-10 23:39 Kyle_Katarn Assigned To => Kyle_Katarn
2010-11-10 23:39 Kyle_Katarn Status new => acknowledged
2010-12-04 15:47 Kyle_Katarn Status acknowledged => resolved
2010-12-04 15:47 Kyle_Katarn Fixed in Version => 2.10.5
2010-12-04 15:47 Kyle_Katarn Resolution open => fixed
2010-12-07 03:18 war59312 Note Added: 0000623
2010-12-07 03:18 war59312 Status resolved => feedback
2010-12-07 03:18 war59312 Resolution fixed => reopened
2010-12-07 20:58 Kyle_Katarn Note Added: 0000624
2010-12-07 21:24 war59312 Note Added: 0000625
2010-12-07 21:24 war59312 Status feedback => assigned
2010-12-22 10:41 Kyle_Katarn Note Added: 0000626
2010-12-22 10:42 Kyle_Katarn Status assigned => resolved
2010-12-22 10:42 Kyle_Katarn Fixed in Version 2.10.5 => 2.10.6
2010-12-22 10:42 Kyle_Katarn Resolution reopened => fixed
2010-12-22 21:03 war59312 Note Added: 0000627
2010-12-22 21:03 war59312 Status resolved => feedback
2010-12-22 21:03 war59312 Resolution fixed => reopened
2010-12-22 22:44 Kyle_Katarn Note Added: 0000628
2010-12-22 22:46 war59312 Note Added: 0000629
2010-12-22 22:46 war59312 Status feedback => assigned
2010-12-22 22:48 Kyle_Katarn Status assigned => resolved
2010-12-22 22:48 Kyle_Katarn Resolution reopened => fixed