View Issue Details

IDProjectCategoryView StatusLast Update
0001584SUMoBugpublic2012-11-08 18:46
ReporterpoutnikgAssigned ToKyle_Katarn 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformDesktopOSWindows Vista 64OS VersionHome Premium SP2
Product Version3.1.2 
Target VersionFixed in Version3.4.1 
Summary0001584: SUMO does not detect both 32bit + 64bit java instalation - mutualy excluding items
DescriptionSUMO does not properly detect both 32bit + 64bit java instalation, their items are mutually excluding.

SUMO does not detect 32bit java ( java 7 ) in Program Files (x86) folder,
if 64bit java is present in Program Files folder.

If java.exe 32b is manually added, it replaces java.exe 64bit.
Additional InformationThe situation seems to be similar as when 32bit VirtualDub were mutually excluding with 64bit VirtualDub.

Could be general design issue for managing 32b and 64b instances of programs on 64b Windows.
TagsNo tags attached.

Relationships

related to 0001662 resolvedKyle_Katarn Adobe Flash Player for IE/FF 64bits not detected 
child of 0001668 resolvedKyle_Katarn SUMo gets confused by file system redirector under Win x64 

Activities

Kyle_Katarn

2012-08-23 10:47

administrator   ~0001184

Isn't this fixed since 3.4.x (use of PE32+ tag) ?

bytehead

2012-08-23 13:58

reporter   ~0001185

64/32 seems OK to me now. Poutnikg?

P.S. There's another issues, of course, with proper handling of parallel branches (there should be a way to show only relevant 6.* updates for JRE 6 even though JRE 7 exists)

bytehead

2012-08-23 13:59

reporter  

Kyle_Katarn

2012-08-23 16:35

administrator   ~0001186

Then this deserve to get closed.
Parallel branches is a totally different problem (but a real one !!)

Issue History

Date Modified Username Field Change
2012-06-02 14:28 poutnikg New Issue
2012-06-02 15:19 Kyle_Katarn Assigned To => Kyle_Katarn
2012-06-02 15:19 Kyle_Katarn Status new => acknowledged
2012-08-08 09:24 Kyle_Katarn Relationship added related to 0001662
2012-08-08 20:05 bytehead Relationship added child of 0001668
2012-08-23 10:47 Kyle_Katarn Note Added: 0001184
2012-08-23 10:47 Kyle_Katarn Status acknowledged => feedback
2012-08-23 13:58 bytehead Note Added: 0001185
2012-08-23 13:59 bytehead File Added: JRE_64_vs_32_detection_(v3.4+).png
2012-08-23 16:35 Kyle_Katarn Note Added: 0001186
2012-08-23 16:35 Kyle_Katarn Status feedback => resolved
2012-08-23 16:35 Kyle_Katarn Fixed in Version => 3.4.1
2012-08-23 16:35 Kyle_Katarn Resolution open => fixed