View Issue Details

IDProjectCategoryView StatusLast Update
0001601SUMoRefactoringpublic2013-12-28 16:17
ReporterpoutnikgAssigned ToKyle_Katarn 
PriorityhighSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformDesktopOSWindows Vista 64OS VersionHome Premium SP2
Product Version3.1.4 
Target VersionFixed in Version3.10.0 
Summary0001601: Stopping update check in case of server is busy/connection troubles
DescriptionTime by time happens during update check, that in spite of "Master server online" in status line, SW item check is timed out. After that checking goes to next item and the time out loop repeats.

After some minutes it ends with cleared available version column.

I thing SUMO should stop with message like
"Server is busy, or there are connection problems. Pleaae, try later, or check the connection."
Tagscheck, time out

Relationships

related to 0001604 resolvedKyle_Katarn If server is online, SUMo should not be so prone de declare timeouts 

Activities

poutnikg

2012-06-11 22:22

reporter   ~0000865

Last edited: 2012-06-11 22:23

View 3 revisions

Hm, funny, now I performed Check and in the half appeared
( for the first time ever for me ) message

Server timeout, please try later.

But it seems does not cover all failing scenarios,
like silent timeouts foor every item.

Kyle_Katarn

2012-06-16 22:51

administrator   ~0000872

It should not loop (fails once and stops)
Please post log + screenshot.

poutnikg

2012-06-16 22:58

reporter   ~0000875

Last edited: 2012-06-16 22:59

View 2 revisions

Hm, I have to wait to kcsoftware not responsive. :-)
Like if it knew what we talk about, it works like a charm.

Kyle_Katarn

2012-06-16 23:11

administrator   ~0000877

Lol, thanks :)

I've been working on server scripts today in order to improve the situation of the past week with lots of server performance troubles ...

poutnikg

2012-06-16 23:13

reporter   ~0000878

Side question,

what if a kind of batch query
would have better overall performance
than querying item per item, as seen in the log ?

Kyle_Katarn

2012-06-17 09:16

administrator   ~0000882

Sure but would significantly change the server/client architecture.
Maybe for SUMo v4 :)

poutnikg

2012-06-19 14:50

reporter   ~0000889

Today a while ago I have tried Check at "Master server online SLOW" status.
There was about 90 apps, checking was in fact quite fast, with some 3-4 short 1/2-1s ( guess) pauses.

No issue... :)

Kyle_Katarn

2012-06-19 21:03

administrator   ~0000890

Server SLOW not **ALWAYS** mean that request will take more time. But it is an indication based on simple HTTP request time

poutnikg

2012-06-20 06:47

reporter   ~0000891

I see. I have just taken it as a higher probability of success of failure. :-)

Kyle_Katarn

2012-06-20 22:30

administrator   ~0000892

Right :)

poutnikg

2012-06-26 21:05

reporter   ~0000905

Last edited: 2012-06-26 21:07

View 2 revisions

Screesnhot here http://img812.imageshack.us/img812/6854/snap208w.png
sumo.log attached as a file.

There were 3 not fully successful updates.
the middle one with stop user cancelling, the first and last uuto cancelled by SUMO with "Server timeout, please try later.

Part of not updated info update seems to be deleted.

Kyle_Katarn

2012-06-26 22:33

administrator   ~0000907

Thanks

Issue History

Date Modified Username Field Change
2012-06-11 22:13 poutnikg New Issue
2012-06-11 22:22 poutnikg Note Added: 0000865
2012-06-11 22:22 poutnikg Note Edited: 0000865 View Revisions
2012-06-11 22:23 poutnikg Note Edited: 0000865 View Revisions
2012-06-12 07:31 poutnikg Tag Attached: check
2012-06-12 07:31 poutnikg Tag Attached: time out
2012-06-12 21:57 Kyle_Katarn Assigned To => Kyle_Katarn
2012-06-12 21:57 Kyle_Katarn Status new => acknowledged
2012-06-16 22:51 Kyle_Katarn Note Added: 0000872
2012-06-16 22:51 Kyle_Katarn Status acknowledged => feedback
2012-06-16 22:58 poutnikg Note Added: 0000875
2012-06-16 22:58 poutnikg Status feedback => assigned
2012-06-16 22:59 poutnikg Note Edited: 0000875 View Revisions
2012-06-16 23:11 Kyle_Katarn Note Added: 0000877
2012-06-16 23:13 poutnikg Note Added: 0000878
2012-06-17 09:16 Kyle_Katarn Note Added: 0000882
2012-06-19 14:50 poutnikg Note Added: 0000889
2012-06-19 21:03 Kyle_Katarn Note Added: 0000890
2012-06-20 06:47 poutnikg Note Added: 0000891
2012-06-20 22:30 Kyle_Katarn Note Added: 0000892
2012-06-26 21:05 poutnikg Note Added: 0000905
2012-06-26 21:07 poutnikg Note Edited: 0000905 View Revisions
2012-06-26 22:33 Kyle_Katarn Note Added: 0000907
2012-06-28 22:50 Kyle_Katarn Relationship added related to 0001604
2012-06-28 22:50 Kyle_Katarn Status assigned => acknowledged
2013-12-28 16:17 Kyle_Katarn Status acknowledged => resolved
2013-12-28 16:17 Kyle_Katarn Fixed in Version => 3.10.0
2013-12-28 16:17 Kyle_Katarn Resolution open => fixed