View Issue Details

IDProjectCategoryView StatusLast Update
0001655SUMoBugpublic2012-08-11 23:14
ReporterFreezeFINAssigned ToKyle_Katarn 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSN/AOS VersionN/A
Product Version3.3.2 
Target VersionFixed in Version3.4.1 
Summary0001655: Install folder files reported as outdated
DescriptionSeveral application create an installation file folder somewhere in the system. SuMO identifies these files as outdated which maybe tru, however the actual installed apllication could very well be up-to date.

Example: PerfectDisk 12.5 Professional

One of the install file folders created during install -->
C:\Program Files (x86)\Raxco\PD12.5_Pro_Install\x64\Program Files 64\Raxco\PerfectDisk\<several>.exe

... contains several files, most of them reported out-of-date by SuMO. The actual installed applkication is up-to-date.
Steps To ReproduceInstall original "vanilla" release of PerfectDisk 12.5 Pro, don't delete the installation fiule folder (as most people will not).
TagsNo tags attached.

Relationships

has duplicate 0001674 resolvedKyle_Katarn updater and installer 

Activities

Kyle_Katarn

2012-08-03 22:18

administrator   ~0001003

Do you have other exemple ?

FreezeFIN

2012-08-04 09:58

reporter   ~0001013

Add the moment, no. I've seen a couple of others, too - but I've deleted the folders a while ago. I just though I'd bring this to your attention.

I'll post more cases, when & if I come across them. But the one I mentioned is solid one... it's been hanging there since I updated PerfectDisk some time ago.

Kyle_Katarn

2012-08-04 13:39

administrator   ~0001016

Thanks. Then, for the time being, i'll wait for feedback and i'd suggest to "ignore" these iteams for the time being.

bytehead

2012-08-09 00:25

reporter   ~0001063

Added some more evidence from nVidia (see attach.)

bytehead

2012-08-09 00:29

reporter  

bytehead

2012-08-09 00:31

reporter   ~0001064

Oops, forgot to rerun a version check ;) New screenshot added.

P.S. Kyle, is it possible to delete posted attachments here?

Kyle_Katarn

2012-08-09 23:51

administrator   ~0001073

Done.
Should i ignore path containng "\install*\" or "\*installer\" ? No side effect (like "\Revo Uninstaller\") ?

bytehead

2012-08-10 01:17

reporter   ~0001081

Last edited: 2012-08-10 03:27

View 4 revisions

I think all these exceptions should be user-customizable, like a simple txt file in user profile with exception masks. We don't even need any UI for it (at least for now), since it will be a feature for power users anyway.

The syntax should allow both things:
1) exclude masks, e.g. "[-] \*install*\"
2) not exclude masks (must have higher priority), e.g. "[+] \revo*\"

Masks should be case insensitive, of course. Log file should reflect every final exclusion decision made from these rules for each processed item. Also, all current hard-coded exceptions should be moved over there.

This way we can handle this very carefully and make it better all the time with the help from community and without recompiling/upgrading SUMo itself.

Kyle_Katarn

2012-08-10 23:31

administrator   ~0001083

Right.

bytehead

2012-08-11 00:58

reporter   ~0001087

Status -> acknowledged/assigned then?

Issue History

Date Modified Username Field Change
2012-08-03 19:48 FreezeFIN New Issue
2012-08-03 19:48 FreezeFIN File Added: sumo_bug.png
2012-08-03 22:18 Kyle_Katarn Note Added: 0001003
2012-08-03 22:18 Kyle_Katarn Assigned To => Kyle_Katarn
2012-08-03 22:18 Kyle_Katarn Status new => feedback
2012-08-04 09:58 FreezeFIN Note Added: 0001013
2012-08-04 09:58 FreezeFIN Status feedback => assigned
2012-08-04 13:39 Kyle_Katarn Note Added: 0001016
2012-08-04 13:39 Kyle_Katarn Status assigned => feedback
2012-08-09 00:24 bytehead File Added: nVidia install entries.png
2012-08-09 00:25 bytehead Note Added: 0001063
2012-08-09 00:29 bytehead File Added: nVidia install entries (with updates info).png
2012-08-09 00:31 bytehead Note Added: 0001064
2012-08-09 23:50 Kyle_Katarn File Deleted: nVidia install entries.png
2012-08-09 23:51 Kyle_Katarn Note Added: 0001073
2012-08-10 01:17 bytehead Note Added: 0001081
2012-08-10 01:31 bytehead Note Edited: 0001081 View Revisions
2012-08-10 01:38 bytehead Note Edited: 0001081 View Revisions
2012-08-10 03:27 bytehead Note Edited: 0001081 View Revisions
2012-08-10 23:31 Kyle_Katarn Note Added: 0001083
2012-08-11 00:58 bytehead Note Added: 0001087
2012-08-11 13:18 bytehead Relationship added related to 0001674
2012-08-11 13:50 Kyle_Katarn Status feedback => acknowledged
2012-08-11 14:35 bytehead Relationship replaced has duplicate 0001674
2012-08-11 23:14 Kyle_Katarn Status acknowledged => resolved
2012-08-11 23:14 Kyle_Katarn Fixed in Version => 3.4.1
2012-08-11 23:14 Kyle_Katarn Resolution open => fixed