View Issue Details

IDProjectCategoryView StatusLast Update
0001656SUMoBugpublic2012-08-12 00:02
ReporterKyle_KatarnAssigned ToKyle_Katarn 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.3.2 
Target VersionFixed in Version3.4.1 
Summary0001656: Duplicate filter not working [properly]
DescriptionDuplicate filter not working [as it was initially intended.]

//from bytehead:
+ it needs to be modified to also take into account file paths (in order not to hide other instances of the same apps/components in different locations);
TagsNo tags attached.

Relationships

related to 0001177 closedKyle_Katarn Duplicate filter not working (at least for SUMo itself) 

Activities

Kyle_Katarn

2012-08-08 15:06

administrator  

screen.png (139,010 bytes)
screen.png (139,010 bytes)

Kyle_Katarn

2012-08-08 15:07

administrator   ~0001045

screen.png : Sometimes the dupliate entry is NOT just right after the current one.

bytehead

2012-08-08 15:29

reporter   ~0001046

Last edited: 2012-08-08 15:54

View 2 revisions

I don't see any *true* duplicates here: some entries just have common {Product;Company;Version} properties, but always different file names and/or bitness. Whats wrong with that?

Of course, it would be perfect if SUMo could somehow show only main .exe file from any application package (without all these redundant components), but so far I don't see how this can be achieved under current design. So, for me its more of a feature, not a bug ;)

P.S. For now the only remedy is to ignore redundant items manually (when 0001664 is fixed, of course)

Kyle_Katarn

2012-08-08 21:37

administrator   ~0001052

You have multiple items with exact same
{ Name+bitness / Company / version number }

Duplicate filter has been implemted to "merge" all these into 1 single line.

bytehead

2012-08-08 23:23

reporter   ~0001061

Last edited: 2012-08-08 23:27

View 2 revisions

Actually I was just planning on filing a separate bug report to change this original behavior. My idea was that duplicate items filter must always take into account full file names, i.e. use {Product[+bitness];Company;Version;Full_File_Name} combo. Otherwise, current ["fixed"] implementation would not only lessen redundant components in the list as on my screenshot (your original intention, I guess), but also would hide all other copies of the same app/component in other locations. AFAICT, this is bad at least for:

a) popular 3d party components bundled with other apps, that sometimes require manual updates (mostly out of security concerns);
b) portable apps of the same version installed alongside "normal" ones (because of privacy concerns or just for testing).

A compromise solution would be to only add File_Path (w/o file name) to the deduplication filter, this would allow to collapse most redundant entries (like in my case), while also taking care of the above a) and b) use cases. What do you think?

Kyle_Katarn

2012-08-08 23:47

administrator   ~0001062

Your compromise is probably the wisest way to go.

Issue History

Date Modified Username Field Change
2012-08-03 22:21 Kyle_Katarn New Issue
2012-08-03 22:21 Kyle_Katarn Status new => assigned
2012-08-03 22:21 Kyle_Katarn Assigned To => Kyle_Katarn
2012-08-03 22:21 Kyle_Katarn File Added: sumo_bug.png
2012-08-03 22:21 Kyle_Katarn Issue generated from: 0001177
2012-08-03 22:21 Kyle_Katarn Relationship added related to 0001177
2012-08-08 15:06 Kyle_Katarn File Added: screen.png
2012-08-08 15:07 Kyle_Katarn Note Added: 0001045
2012-08-08 15:29 bytehead Note Added: 0001046
2012-08-08 15:54 bytehead Note Edited: 0001046 View Revisions
2012-08-08 15:56 bytehead Relationship added related to 0001664
2012-08-08 21:37 Kyle_Katarn Note Added: 0001052
2012-08-08 23:23 bytehead Note Added: 0001061
2012-08-08 23:27 bytehead Note Edited: 0001061 View Revisions
2012-08-08 23:47 Kyle_Katarn Note Added: 0001062
2012-08-09 20:06 bytehead Summary Duplicate filter not working => Duplicate filter not working [properly]
2012-08-09 20:06 bytehead Description Updated View Revisions
2012-08-12 00:02 Kyle_Katarn Status assigned => resolved
2012-08-12 00:02 Kyle_Katarn Fixed in Version => 3.4.1
2012-08-12 00:02 Kyle_Katarn Resolution open => fixed
2012-08-12 00:03 Kyle_Katarn Relationship deleted related to 0001664