View Issue Details

IDProjectCategoryView StatusLast Update
0001662SUMoRefactoringpublic2012-08-17 01:46
ReporterKyle_KatarnAssigned ToKyle_Katarn 
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.4.3 
Summary0001662: Adobe Flash Player for IE/FF 64bits not detected
DescriptionAdobe Flash Player for IE/FF 64bits not detected

Not PE32+ ?
Filename to be used ?
TagsNo tags attached.

Relationships

related to 0001584 resolvedKyle_Katarn SUMO does not detect both 32bit + 64bit java instalation - mutualy excluding items 
related to 0001582 resolvedKyle_Katarn SUMO does not detect 64bit Adobe Flash Player plugins 
child of 0001668 resolvedKyle_Katarn SUMo gets confused by file system redirector under Win x64 

Activities

poutnikg

2012-08-06 10:51

reporter   ~0001034

Related to http://www.kcsoftwares.com/bugs/view.php?id=1582

poutnikg

2012-08-06 10:54

reporter   ~0001035

Last edited: 2012-08-08 08:41

View 2 revisions

Funny, for me at the moment it detects ONLY 64 bit ones, but not 32 ones.

bytehead

2012-08-08 00:22

reporter   ~0001038

Last edited: 2012-08-08 00:56

View 3 revisions

I just checked my setup under c:\Windows\System32\Macromed\Flash\:

FlashUtil64_11_3_300_270_ActiveX.dll
FlashUtil64_11_3_300_270_ActiveX.exe
Flash64_11_3_300_270.ocx
FlashUtil64_11_3_300_270_Plugin.exe
NPSWF64_11_3_300_270.dll

For me SUMo lists only 32-bit parts in the GUI, but the log shows all (albeit w/o exe helpers):
<...>
Verbose [12-08-07 21:18:59] Loading 454/458 : C:\Windows\SysWOW64\Macromed\Flash\NPSWF32_11_3_300_270.dll
Verbose [12-08-07 21:18:59] Loading 453/458 : C:\Windows\SysWOW64\Macromed\Flash\FlashUtil32_11_3_300_270_ActiveX.dll
Verbose [12-08-07 21:18:59] Loading 452/458 : C:\Windows\SysWOW64\Macromed\Flash\Flash32_11_3_300_270.ocx
Verbose [12-08-07 21:18:59] Loading 451/458 : C:\Windows\System32\Macromed\Flash\NPSWF64_11_3_300_270.dll
Verbose [12-08-07 21:18:59] Loading 450/458 : C:\Windows\System32\Macromed\Flash\FlashUtil64_11_3_300_270_ActiveX.dll
Verbose [12-08-07 21:18:59] Loading 449/458 : C:\Windows\System32\Macromed\Flash\Flash64_11_3_300_270.ocx
<...>

According to MiTeC EXE Explorer (http://www.mitec.cz/exe.html) all these files are properly tagged 64-bit PE binaries:

Machine = AMD64 (0x8664)
PEType = PE32+ (0x020b)

So, both 32 and 64 bit Flash components are correctly found while scanning, but somehow 64-bit parts get lost later on. Could this be due to duplicate items filter usage in the list? If so, you also need to take into account *full* file names (with paths) when filtering, not just {Product;Company} combo.

P.S. Here is the official Microsoft PE and COFF Specification just in case: http://msdn.microsoft.com/library/windows/hardware/gg463125

bytehead

2012-08-08 01:36

reporter   ~0001039

Last edited: 2012-08-08 01:40

View 2 revisions

Btw, this problem is not unique to Flash. JRE 6/7 has exactly the same issue, only reversed in my case. SUMo initially detected all 32- and 64-bit installations of both JRE 6 and JRE 7 branches, while ended up listing only x64 components (except for Java Update tools and Java Quick Starter binary which don't have 64-bit counterparts).

Investigating further, it seems to be a generic problem of mutual exclusion of items that have the same {Product;Company;Version(?)} tagging, disregarding *both* file name *and* location differences. That means that the issue has nothing to do with the 32/64 bitness per se and if you have several copies of the same file just in different locations, SUMo will list only one instance, too! Just verified it.

poutnikg

2012-08-08 09:02

reporter   ~0001040

Related to
0001584: SUMO does not detect both 32bit + 64bit java instalation - mutualy excluding items
http://www.kcsoftwares.com/bugs/view.php?id=1584

Kyle_Katarn

2012-08-08 09:24

administrator   ~0001041

relationship added

Kyle_Katarn

2012-08-08 09:26

administrator   ~0001042

This will automatically solved as soon as SUMo will detec these files as 64bits variants, either thru PE32+ or file names. Then, (64 bits) will be added to its product name and it would no longer be removed by duplicate filter (same product / company /version)

Kyle_Katarn

2012-08-08 10:16

administrator   ~0001043

Would you please zip and attache all files in this directory, so that i can test on my machine ?

bytehead

2012-08-08 20:09

reporter   ~0001048

Hoorey! I seem to have found the root cause of these 32/64-bit issues. See bug 0001668 for details.

P.S. this was a nasty one! ;)

Kyle_Katarn

2012-08-08 21:51

administrator   ~0001057

This will be of some help : http://embarcadero.newsgroups.archived.at/public.delphi.language.delphi.win32/201003/1003028626.html

Issue History

Date Modified Username Field Change
2012-08-05 11:05 Kyle_Katarn New Issue
2012-08-05 11:05 Kyle_Katarn Assigned To => Kyle_Katarn
2012-08-05 11:05 Kyle_Katarn Status new => acknowledged
2012-08-06 10:51 poutnikg Note Added: 0001034
2012-08-06 10:54 poutnikg Note Added: 0001035
2012-08-07 21:59 Kyle_Katarn Relationship added related to 0001582
2012-08-08 00:22 bytehead Note Added: 0001038
2012-08-08 00:24 bytehead Note Edited: 0001038 View Revisions
2012-08-08 00:56 bytehead Note Edited: 0001038 View Revisions
2012-08-08 01:36 bytehead Note Added: 0001039
2012-08-08 01:40 bytehead Note Edited: 0001039 View Revisions
2012-08-08 08:41 poutnikg Note Edited: 0001035 View Revisions
2012-08-08 09:02 poutnikg Note Added: 0001040
2012-08-08 09:24 Kyle_Katarn Relationship added related to 0001584
2012-08-08 09:24 Kyle_Katarn Note Added: 0001041
2012-08-08 09:26 Kyle_Katarn Note Added: 0001042
2012-08-08 09:26 Kyle_Katarn Status acknowledged => feedback
2012-08-08 10:16 Kyle_Katarn Note Added: 0001043
2012-08-08 10:16 Kyle_Katarn Status feedback => assigned
2012-08-08 16:00 bytehead Priority normal => high
2012-08-08 16:00 bytehead Severity minor => major
2012-08-08 20:03 bytehead Relationship added child of 0001668
2012-08-08 20:09 bytehead Note Added: 0001048
2012-08-08 21:51 Kyle_Katarn Note Added: 0001057
2012-08-17 01:46 Kyle_Katarn Status assigned => resolved
2012-08-17 01:46 Kyle_Katarn Fixed in Version => 3.4.3
2012-08-17 01:46 Kyle_Katarn Resolution open => fixed