View Issue Details

IDProjectCategoryView StatusLast Update
0001672SUMoBugpublic2012-08-11 23:39
ReporterbyteheadAssigned ToKyle_Katarn 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.4 
Target VersionFixed in Version3.4.1 
Summary0001672: Make SUMo distinguish similar looking items with different file names when collecting/mapping version data
DescriptionSUMo should use {Product[+bitness];Company;File_Name}->{Version} mapping scheme instead of current {Product[+bitness?];Company}->{Version} scheme to stop misreporting updates for different but equally tagged components under different file names.
Steps To ReproduceSee attached screenshots for an example.

For ref.:
 * "MAC.exe" is a console front-end and its latest official revision is 3.99 indeed;
 * "Monkey's Audio.exe" is a GUI front-end of the same app, it's latest available version is 4.10.

AFAIK, there's no mac.exe of v4.10.0.0 (last build is from April 16, 2011).
see http://www.monkeysaudio.com/index.html
Additional InformationActually I've got one more MAC.exe under "c:\Program Files (x86)\Monkey's Audio", but it's missing here due to bug 0001656.
TagsNo tags attached.

Activities

bytehead

2012-08-10 05:21

reporter  

bytehead

2012-08-10 05:21

reporter  

mac.exe.png (35,411 bytes)
mac.exe.png (35,411 bytes)

bytehead

2012-08-10 05:22

reporter  

Monkey\'s Audio.exe.png (37,703 bytes)
Monkey\'s Audio.exe.png (37,703 bytes)

Kyle_Katarn

2012-08-11 23:39

administrator   ~0001094

Partially resolved.

Datamodel still relies on Name / Company / Version scheme but MAC specific problem has been adressed as i know it is a burden for many users.

In this case, of description if not null, it is used instead of product name, which helps to differentiate these 2 products.

Issue History

Date Modified Username Field Change
2012-08-10 05:21 bytehead New Issue
2012-08-10 05:21 bytehead File Added: wrong update info (for similar looking components).png
2012-08-10 05:21 bytehead File Added: mac.exe.png
2012-08-10 05:22 bytehead File Added: Monkey\'s Audio.exe.png
2012-08-10 23:29 Kyle_Katarn Assigned To => Kyle_Katarn
2012-08-10 23:29 Kyle_Katarn Status new => acknowledged
2012-08-11 23:39 Kyle_Katarn Note Added: 0001094
2012-08-11 23:39 Kyle_Katarn Status acknowledged => resolved
2012-08-11 23:39 Kyle_Katarn Fixed in Version => 3.4.1
2012-08-11 23:39 Kyle_Katarn Resolution open => fixed