View Issue Details

IDProjectCategoryView StatusLast Update
0002026SUMoBugpublic2013-07-07 00:50
ReporterbyteheadAssigned ToKyle_Katarn 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformIntel x64OSWindows 7OS VersionUltimate x64 SP1
Product Version3.7 
Target VersionFixed in Version3.7.1 
Summary0002026: Intermittently inconsistent results
Description_Sometimes_ latest update versions reported by SUMo is inconsistent -- on the first check it may show one set of out-of-date items (longer one), on the manual selection recheck or on the full recheck after immediate SUMo restart -- it may show a shorter list (some out-of-date items become up-to-date all of a sudden).
Steps To ReproduceThis is not _always_ reproducible, but quite often. I did the following (see attachment for details):

1) erased SUMo.cache for cleaner test;
2) launched SUMo and saved the out-of-date list;
3) resarted SUMo and checked everything again;
4) selected reported out-of-date items and rechecked them via context menu;

I have "Check for updates at startup" enabled.
TagsNo tags attached.

Relationships

related to 0002023 resolvedKyle_Katarn Version are not refreshed when clicking on "check" (but right click menu does reload) 

Activities

bytehead

2013-06-27 17:34

reporter  

check1_clear_cache.png (78,148 bytes)
check1_clear_cache.png (78,148 bytes)

bytehead

2013-06-27 17:34

reporter  

check2_after_restart.png (67,386 bytes)
check2_after_restart.png (67,386 bytes)

bytehead

2013-06-27 17:34

reporter  

check3_selection.png (76,993 bytes)
check3_selection.png (76,993 bytes)

bytehead

2013-06-27 17:36

reporter  

SUMo-1.log (71,434 bytes)

bytehead

2013-06-27 17:36

reporter  

SUMo-2.log (5,251 bytes)

bytehead

2013-06-27 17:38

reporter  

SUMo-3.log (5,105 bytes)

bytehead

2013-06-27 17:46

reporter   ~0001460

In this particular case after immediate restart it even _added_ one as if out-of-date item (ActiveState Komodo), then marked it as OK again after selective recheck.

bytehead

2013-06-27 17:50

reporter   ~0001461

Also, notice unicode issues on the last screenshot -- presumed chinese characters are shown as question marks. Kyle, is it a Delfi 7 limitation? Have you tried Lazarus instead lately?

Kyle_Katarn

2013-06-27 21:23

administrator   ~0001462

Looks duplicate of 0002023 i've dicovered a few days ago.

"???" seems to be a non-unicode implementation if D7.

Issue History

Date Modified Username Field Change
2013-06-27 17:34 bytehead New Issue
2013-06-27 17:34 bytehead File Added: check1_clear_cache.png
2013-06-27 17:34 bytehead File Added: check2_after_restart.png
2013-06-27 17:34 bytehead File Added: check3_selection.png
2013-06-27 17:36 bytehead File Added: SUMo-1.log
2013-06-27 17:36 bytehead File Added: SUMo-2.log
2013-06-27 17:38 bytehead File Added: SUMo-3.log
2013-06-27 17:46 bytehead Note Added: 0001460
2013-06-27 17:50 bytehead Note Added: 0001461
2013-06-27 21:22 Kyle_Katarn Relationship added related to 0002023
2013-06-27 21:23 Kyle_Katarn Note Added: 0001462
2013-06-27 21:24 Kyle_Katarn Assigned To => Kyle_Katarn
2013-06-27 21:24 Kyle_Katarn Status new => acknowledged
2013-07-07 00:50 Kyle_Katarn Status acknowledged => resolved
2013-07-07 00:50 Kyle_Katarn Fixed in Version => 3.7.1
2013-07-07 00:50 Kyle_Katarn Resolution open => fixed