View Issue Details

IDProjectCategoryView StatusLast Update
0002427SUMoBugpublic2015-08-31 11:20
ReporterBluestarAssigned ToKyle_Katarn 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.10.2 
Target Version4.1Fixed in Version4.1 
Summary0002427: Unchanged, incorrect strings after switching language to another one (Settings dialog)
DescriptionAfter choosing another language inside the "Settings" dialog, some item just misses to reload, so their string keep being written using the previous Language.

Note: It works only in case of missing language strings.
Steps To Reproduce01. Open Settings
02. Switch to Finnish (or any other language with some missing language strings)
03. Switch to Traditional Chinese
04. -> Four checkbox items are affected this way
Additional InformationThe way it should behave:
- load the English version of the missing strings of last selected language
TagsNo tags attached.

Activities

Bluestar

2014-01-05 01:02

reporter  

language_switch_bug.png (48,968 bytes)
language_switch_bug.png (48,968 bytes)

Bluestar

2014-01-05 01:45

reporter   ~0001567

Last edited: 2014-01-05 01:51

View 2 revisions

Note 1: "Drivers Update" button in the main window is affected as well. (as its relatively a new translation string)

Bluestar

2014-01-05 01:52

reporter   ~0001568

Note 2: the right click context menu in the main form is also affected (e.g. "Skip this update" and "More by %s" items)

Kyle_Katarn

2015-08-20 21:53

administrator   ~0002000

Would you please install this test version of SUMo v4.0.7 : http://www.kcsoftwares.com/beta/sumo_vstore.exe and tell me if the problem is fixed ?

Bluestar

2015-08-24 22:12

reporter   ~0002017

Thanks, now it seems to be fine in this 4.0.7 build!

Kyle_Katarn

2015-08-24 22:52

administrator   ~0002018

To be fixed on 4.1 installer

Issue History

Date Modified Username Field Change
2014-01-05 01:02 Bluestar New Issue
2014-01-05 01:02 Bluestar File Added: language_switch_bug.png
2014-01-05 01:45 Bluestar Note Added: 0001567
2014-01-05 01:51 Bluestar Note Edited: 0001567 View Revisions
2014-01-05 01:52 Bluestar Note Added: 0001568
2014-01-05 10:48 Kyle_Katarn Assigned To => Kyle_Katarn
2014-01-05 10:48 Kyle_Katarn Status new => acknowledged
2015-08-20 21:53 Kyle_Katarn Note Added: 0002000
2015-08-20 21:53 Kyle_Katarn Status acknowledged => feedback
2015-08-24 22:12 Bluestar Note Added: 0002017
2015-08-24 22:52 Kyle_Katarn Note Added: 0002018
2015-08-24 22:52 Kyle_Katarn Status feedback => assigned
2015-08-24 22:52 Kyle_Katarn Target Version => 4.1
2015-08-31 11:20 Kyle_Katarn Status assigned => resolved
2015-08-31 11:20 Kyle_Katarn Fixed in Version => 4.1
2015-08-31 11:20 Kyle_Katarn Resolution open => fixed