View Issue Details

IDProjectCategoryView StatusLast Update
0002546SUMoBugpublic2014-07-05 03:54
ReporterbyteheadAssigned ToKyle_Katarn 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformIntel x64OSWindows 7OS VersionUltimate x64 SP1
Product Version3.10.11 
Target VersionFixed in Version3.10.12 
Summary0002546: Crash after scan
DescriptionJust updated to v3.10.11 from 3.9.4, it asked to rescan after launch, scanned normally, then crashed after loading has finished ("Loading...done. 2426/2426"). Here's the crash log:

Problem signature:
  Problem Event Name: APPCRASH
  Application Name: SUMo.exe
  Application Version: 3.10.11.238
  Application Timestamp: 2a425e19
  Fault Module Name: KERNELBASE.dll
  Fault Module Version: 6.1.7601.18409
  Fault Module Timestamp: 53159a86
  Exception Code: 0eedfade
  Exception Offset: 0000c42d
  OS Version: 6.1.7601.2.1.0.256.1
  Locale ID: 1049
  Additional Information 1: d822
  Additional Information 2: d82263b2cdd0dbcdf134a452983e2a4b
  Additional Information 3: d78b
  Additional Information 4: d78b9be0f2f797fe33a29061917319ec

Visual Studio 2010 Just-In-Time Debugger says: An unhandled win32 exception occured in SUMo.exe process [796]. Unhandled exception at 0x7decb852 in SUMo.exe: 0xC0000005: Access violation writing location 0x02b40f90. Call stack location: ntdll.dll!7decb852() Thread [2904] Win32 Thread.

TagsNo tags attached.

Activities

bytehead

2014-06-30 18:25

reporter  

error.png (27,453 bytes)
error.png (27,453 bytes)

Kyle_Katarn

2014-06-30 20:59

administrator   ~0001686

May i have SUMo log as well ? Is it systematic ?

bytehead

2014-06-30 21:14

reporter   ~0001689

Here we go - attached. It is absolutely reproducible on my machine. Always crashes after scan is finished.

Kyle_Katarn

2014-06-30 21:17

administrator   ~0001690

Very interesting.
I'll have a test build sent to you. Would you please contact me by email (support [@] kcsoftwares.com)

Kyle_Katarn

2014-06-30 21:22

administrator   ~0001691

Would you please check "debug mode" in settings and retry ? (+post log again)

Thanks !

bytehead

2014-06-30 21:31

reporter   ~0001692

Last edited: 2014-06-30 21:31

View 2 revisions

Done -- crashed exactly the same. Log attached.

Kyle_Katarn

2014-06-30 21:33

administrator   ~0001693

Looks still in standard mode.
Check debug, save settings. Quit SUMo, then retry

Sorry for the long way investigation !

bytehead

2014-06-30 21:40

reporter   ~0001694

Wasn't aware I needed to restart SUMo for debug mode to take effect. It's an old bug iirc -- when debug is checked it says something stupid about some Microsoft stuff being disabled instead. Rerunning...

Kyle_Katarn

2014-06-30 21:41

administrator   ~0001695

thanks !

bytehead

2014-06-30 21:41

reporter  

SUMo_debug2.log (776,391 bytes)

bytehead

2014-06-30 21:43

reporter  

settings_glitch.png (45,611 bytes)
settings_glitch.png (45,611 bytes)

bytehead

2014-06-30 21:46

reporter   ~0001696

Last edited: 2014-07-01 12:37

View 3 revisions

New log attached.

On a side note: does anybody else enconter this weird rendering bug in settings window I just attached? It happens to me from time to time, but I can't reproduce it reliably to file a proper bug report. Maybe it has something to do with nVidia drivers, who knows, but I've never seen it anyware else except in SUMo...

Kyle_Katarn

2014-06-30 22:23

administrator   ~0001697

What does .239 give ?

bytehead

2014-07-01 12:35

reporter   ~0001699

b239 seems ok, no crash so far.

Kyle_Katarn

2014-07-01 21:07

administrator   ~0001700

May i have log from v239 please ?

bytehead

2014-07-04 01:18

reporter  

SUMo_b239.log (845,410 bytes)

bytehead

2014-07-04 01:19

reporter   ~0001702

new debug log uploaded (build 239)

Issue History

Date Modified Username Field Change
2014-06-30 18:25 bytehead New Issue
2014-06-30 18:25 bytehead File Added: error.png
2014-06-30 20:59 Kyle_Katarn Note Added: 0001686
2014-06-30 20:59 Kyle_Katarn Assigned To => Kyle_Katarn
2014-06-30 20:59 Kyle_Katarn Status new => feedback
2014-06-30 21:12 bytehead File Added: SUMo.log
2014-06-30 21:14 bytehead Note Added: 0001689
2014-06-30 21:14 bytehead Status feedback => assigned
2014-06-30 21:14 bytehead Reproducibility have not tried => always
2014-06-30 21:17 Kyle_Katarn Note Added: 0001690
2014-06-30 21:17 Kyle_Katarn Status assigned => feedback
2014-06-30 21:22 Kyle_Katarn Note Added: 0001691
2014-06-30 21:22 Kyle_Katarn File Deleted: SUMo.log
2014-06-30 21:30 bytehead File Added: SUMo-debug.log
2014-06-30 21:31 bytehead Note Added: 0001692
2014-06-30 21:31 bytehead Status feedback => assigned
2014-06-30 21:31 bytehead Note Edited: 0001692 View Revisions
2014-06-30 21:33 Kyle_Katarn Note Added: 0001693
2014-06-30 21:38 Kyle_Katarn File Deleted: SUMo-debug.log
2014-06-30 21:40 bytehead Note Added: 0001694
2014-06-30 21:41 Kyle_Katarn Note Added: 0001695
2014-06-30 21:41 bytehead File Added: SUMo_debug2.log
2014-06-30 21:43 bytehead File Added: settings_glitch.png
2014-06-30 21:46 bytehead Note Added: 0001696
2014-06-30 22:23 Kyle_Katarn Note Added: 0001697
2014-07-01 12:35 bytehead Note Added: 0001699
2014-07-01 12:36 bytehead Note Edited: 0001696 View Revisions
2014-07-01 12:37 bytehead Note Edited: 0001696 View Revisions
2014-07-01 21:07 Kyle_Katarn Note Added: 0001700
2014-07-01 21:07 Kyle_Katarn Status assigned => feedback
2014-07-04 01:18 bytehead File Added: SUMo_b239.log
2014-07-04 01:19 bytehead Note Added: 0001702
2014-07-04 01:19 bytehead Status feedback => assigned
2014-07-04 21:45 Kyle_Katarn Status assigned => resolved
2014-07-04 21:45 Kyle_Katarn Fixed in Version => 3.10.12
2014-07-04 21:45 Kyle_Katarn Resolution open => fixed