View Issue Details

IDProjectCategoryView StatusLast Update
0002902SUMoBugpublic2015-07-05 00:33
ReporterJohan LAssigned ToKyle_Katarn 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWin 7OS Version
Product Version3.14 
Target Version4.0Fixed in Version4.0 
Summary0002902: Skip update not remembered
DescriptionI have both the last 1:st gen Avidemux 2.5.6.0 (some other functions than newer versions) and 2:nd gen 2.6 Avidemux installed, and sumo always mark a new update available for 2.5.6.0 even though I set it to "Skip this update" every time. A bit irritating, but not deal breaking obviously.
TagsNo tags attached.

Relationships

related to 0002816 closedKyle_Katarn Removing old items in skippd version list when newer version is detected as installed 

Activities

Kyle_Katarn

2015-06-21 15:08

administrator   ~0001896

Please attach log file

Johan L

2015-06-21 23:01

reporter  

SUMo_startup.log (16,094 bytes)

Johan L

2015-06-21 23:27

reporter   ~0001897

Added the log file.

Just noticed that I don't have to restart sumo to get it to display an update - if I select "Skip this update" for Avidemux 2.5.6, and then just click "Check" right away again, it pops back immediately and say an update is available. I tried the same with an other program that also had an update, and the update didn't show, as wanted and expected.

I then looked around and found the SUMo.skipped file - an Avidemux line is created when selecting it to be skipped, but when clicking "Check" it is removed from SUMo.skipped. "Debug mode" seem to give some more info in the log file, so I enabled that and will attach a second log from when doing a "Check" right after skipping.

Johan L

2015-06-21 23:27

reporter  

SUMo_debug_check.log (62,315 bytes)

Kyle_Katarn

2015-06-22 20:43

administrator   ~0001900

It is probably due to the fact that you're already have a newer version installed (which "cleans" request for skipping 2.6).

I'll check in the code.

Issue History

Date Modified Username Field Change
2015-06-21 10:39 Johan L New Issue
2015-06-21 15:07 Kyle_Katarn Assigned To => Kyle_Katarn
2015-06-21 15:07 Kyle_Katarn Status new => acknowledged
2015-06-21 15:07 Kyle_Katarn Relationship added related to 0002816
2015-06-21 15:08 Kyle_Katarn Note Added: 0001896
2015-06-21 15:08 Kyle_Katarn Status acknowledged => feedback
2015-06-21 23:01 Johan L File Added: SUMo_startup.log
2015-06-21 23:27 Johan L Note Added: 0001897
2015-06-21 23:27 Johan L Status feedback => assigned
2015-06-21 23:27 Johan L File Added: SUMo_debug_check.log
2015-06-22 20:43 Kyle_Katarn Note Added: 0001900
2015-06-28 19:36 Kyle_Katarn Target Version => 4.0
2015-07-05 00:33 Kyle_Katarn Status assigned => resolved
2015-07-05 00:33 Kyle_Katarn Fixed in Version => 4.0
2015-07-05 00:33 Kyle_Katarn Resolution open => fixed