View Issue Details

IDProjectCategoryView StatusLast Update
0004159SUMoBugpublic2016-12-07 22:10
ReporterinvalidAssigned ToKyle_Katarn 
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Platformx64OSWindows 8.1 EnterpriseOS Version6.3 build 9600
Product Version5.0.8 
Target Version5.0.10Fixed in Version5.0.10 
Summary0004159: Access violation and License details lost after auto-upgrade to version 5.0.8.340 and not able to save it afterwards
DescriptionI started my Sumo Pro to look for new software versions and received Auto-Update message that there is a new version.
Once I've updated my Sumo it restarted automatically as always (when doing Auto Update) and I could see that the button „Buy Sumo Pro“ was there.
I then checked the „About“ section only to see it was not registered.

Then, I entered my license details and received a message saying „Valid License“ and I thought "OK, something must have cleared my License details but I'm good now". But, that wasn't the case, I actually had to register it again and after few more attempts I saw I couldn't resolve it.

Then after a few more retries (I still wasn't gonna give up) with „Valid License“ always shown as a last step of confirming registration details I restarted Sumo and I was offered to Auto-Update it again (strange since it auto-updated about 30 minutes ago, or so).

I cancelled the Auto-Update window, then I entered my license details again, and without restarting Sumo I ran Check For updates manually and once Auto-Update was finished it restarted (as always once auto-update is done).

The error was then shown in foreign language (screenshot attached - Nr. 4), probably French.
Sumo opened and it was on version 5.0.9, the first thing I noticed was that „Buy Sumo Pro“ button was gone and when I checked the „About“ , Sumo was registered, I didn't have to do nothing this time.

Issue resolved.
Steps To Reproduce1. Auto-Update Sumo Pro from 5.0.4 (or maybe it was 5.0.5, this is the only thing I'm not quite sure about, but it was 5.0.4 or 5.0.5, I'm 80 percent sure it was 5.0.4)
2. Register and restart Sumo Pro 5.0.8.340 > many times
3. Auto-Update offered again, but choose cancel
4. Register Sumo 5.0.8 again and without Sumo restart go to Help > Check for Update
5. Auto-Update to 5.0.9
6. Receive error message window with text written in French and click 'OK' - Screenshot 4.
7. Sumo started and was registered using the registration done while on version 5.0.8
Additional InformationAll screenshots are shown in the order as the issue arose and was resolved.
TagsLicense Sumo Pro NOT SAVING

Issue History

Date Modified Username Field Change
2016-11-23 23:14 invalid New Issue
2016-11-23 23:14 invalid File Added: 1. Screen showing unregistered Sumo 5.0.8 after registered version upgrade.png
2016-11-23 23:14 invalid File Added: 2. Screen showing unregistered Sumo 5.0.8 - Entering registration data.png
2016-11-23 23:14 invalid File Added: 3. Screen showing REGISTERED Sumo 5.0.8 - Confirmed Valid License.png
2016-11-23 23:14 invalid File Added: 4. Screen showing error after Auto-Update to Sumo 5.0.9 finished and autorestart of Sumo started.png
2016-11-23 23:14 invalid File Added: 5. Screen showing REGISTERED Sumo 5.0.9 after confirming OK on previous Error message on Screen 4.png
2016-11-23 23:14 invalid Tag Attached: License Sumo Pro NOT SAVING
2016-11-24 21:00 Kyle_Katarn Summary License details lost after auto-upgrade to version 5.0.8.340 and not able to save it afterwards => Access violation and License details lost after auto-upgrade to version 5.0.8.340 and not able to save it afterwards
2016-11-24 21:00 Kyle_Katarn Assigned To => Kyle_Katarn
2016-11-24 21:00 Kyle_Katarn Status new => confirmed
2016-11-24 21:00 Kyle_Katarn Target Version => 5.0.10
2016-12-07 22:10 Kyle_Katarn Status confirmed => resolved
2016-12-07 22:10 Kyle_Katarn Resolution open => fixed
2016-12-07 22:10 Kyle_Katarn Fixed in Version => 5.0.10