View Issue Details

IDProjectCategoryView StatusLast Update
0000519SUMoBugpublic2008-04-13 22:51
ReporterKyle_KatarnAssigned ToKyle_Katarn 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version1.6.3 
Target VersionFixed in Version1.8.1 
Summary0000519: Missing Status Bar and Default Window Size Issues under Windows Vista
Descriptionhttp://www.kcsoftwares.com/forum/viewtopic.php?id=98
TagsNo tags attached.

Activities

Kyle_Katarn

2008-03-24 12:56

administrator   ~0000222

Does the status bar appears under Vista when "stretching" the window ?

Kyle_Katarn

2008-03-24 12:56

administrator   ~0000223

Reminder sent to: Zer0 Voltage

Feedback needed !

Zer0 Voltage

2008-03-24 20:05

reporter   ~0000227

No, it doesn't. As I mentioned in the second to last paragraph of my original long post, stretching the SUMo program window wider or even maximizing it does not reveal the status bar (see the new screenshots I uploaded). Only switching to a non-Vista theme will let it appear.

This doesn't happen with any XP or older themes - only Vista (though it isn't Aero related either).

So there are two problems: (1) the status bar is not available when a Vista theme is used and (2) the default SUMo program window size is slightly too narrow for Vista themes.

Zer0 Voltage

2008-03-24 20:34

reporter   ~0000228

Uploaded another shot showing the same Vista system only with the
"Windows Standard" color scheme selected instead. As you can see, the SUMo program window is then showing the status bar. When I switch back to "Windows Vista Basic" it will disappear again.

Kyle_Katarn

2008-03-24 21:06

administrator   ~0000229

Thanks.

I agree with you, there are 2 different issues
- SUMo's default size is a bit too narrow
- Status bar not visible when using Vista Theme.

Zer0 Voltage

2008-03-25 03:50

reporter   ~0000230

Yeah, it amazes me how many things Microsoft broke with Vista. Since its release I've seen various developers complaining about the strange decisions Microsoft made in what to remove and what to change. You would think that when they want to change the way something works or looks they would also keep some level of backwards compatibility in place, but I guess when you rule the world you can do what you want. :)

Zer0 Voltage

2008-03-25 06:22

reporter   ~0000231

Last edited: 2008-03-25 06:31

By the way, if this information would be of any use to you, the only additional width needed to eliminate the horizontal scroll bar in Vista is a mere 5 pixels. Nope, that's not a typo - it's really just FIVE pixels! :)

What I did to figure this out was open SUMo normally and take a window-shot of it (with Alt+PrtScn). Then I carefully stretched the window wider one pixel at a time until the scroll bar disappeared and took another window-shot. Then I compared those two image file properties. The default window was 544 x 465 pixels and the one without the scroll bar was 549 x 465 pixels.

This was at a 96 dpi horizontal and vertical resolution and 24 bit depth (if that matters). I've uploaded the window-shots (SUMo-Vista-Scrollbar.jpg and SUMo-Vista-NoBar.jpg) in case you want to see them.

Kyle_Katarn

2008-03-25 20:26

administrator   ~0000232

Thanks !

Orionizer

2008-03-30 13:53

reporter   ~0000236

Confirmed here as well using Vista32...

Orionizer

2008-03-30 13:54

reporter   ~0000237

Also, should this article status be changed from "Feedback" to "Acknowledged"?

Zer0 Voltage

2008-03-30 23:54

reporter   ~0000242

You know, I spent some time researching this - trying to find the actual cause of the missing status bar - but I couldn't find anything. I even went through the entire list of Vista GUI and interface changes and nothing even sounded like it might accidentally cause this as a side-effect of something else.

The only other slightly similar problem was with Vista users reporting the Internet Explorer status bar disappearing, but in those cases it just ended up being that the Status Bar entry wasn't selected under the View menu.

But since IE lets you turn the status bar on and off, this implies that Microsoft provides some sort of switch for this somewhere. Perhaps for some reason Vista just sees that switch as being off with SUMo when a Vista color scheme is selected?

Zer0 Voltage

2008-04-13 22:36

reporter   ~0000305

Last edited: 2008-04-13 22:40

Guess what... This is fixed in version 1.8!

I see this report is still open, however, so was this actually expected?

If not, something done in the 1.8 code had the unexpected side-effect of fixing this problem too.

I'm positive it's the 1.8 code since I fully uninstalled it and then reinstalled v1.7.0.42 and the problem returned. As soon as I upgraded to the v1.8.0.43 beta code it was fixed - and it remains fixed in the official 1.8.0.44 release.

Screenshots attached for verification: SUMo-1.8-Vista-Loading.jpg and SUMo-1.8-Vista-Checking.jpg

Issue History

Date Modified Username Field Change
2008-03-22 09:41 Kyle_Katarn New Issue
2008-03-22 09:41 Kyle_Katarn File Added: sumocheckxprh6.jpg
2008-03-22 09:42 Kyle_Katarn File Added: sumocheckvistawz6.jpg
2008-03-22 09:42 Kyle_Katarn Assigned To => Kyle_Katarn
2008-03-22 09:42 Kyle_Katarn Status new => acknowledged
2008-03-24 12:56 Kyle_Katarn Note Added: 0000222
2008-03-24 12:56 Kyle_Katarn Status acknowledged => feedback
2008-03-24 12:56 Kyle_Katarn Note Added: 0000223
2008-03-24 20:05 Zer0 Voltage Note Added: 0000227
2008-03-24 20:05 Zer0 Voltage File Added: Vista-Stretched.jpg
2008-03-24 20:06 Zer0 Voltage File Added: Vista-Maximized.jpg
2008-03-24 20:32 Zer0 Voltage File Added: Vista-Windows-Standard-Theme.jpg
2008-03-24 20:34 Zer0 Voltage Note Added: 0000228
2008-03-24 21:06 Kyle_Katarn Note Added: 0000229
2008-03-25 03:50 Zer0 Voltage Note Added: 0000230
2008-03-25 06:22 Zer0 Voltage Note Added: 0000231
2008-03-25 06:29 Zer0 Voltage File Added: SUMo-Vista-Scrollbar.jpg
2008-03-25 06:29 Zer0 Voltage File Added: SUMo-Vista-NoBar.jpg
2008-03-25 06:30 Zer0 Voltage Note Edited: 0000231
2008-03-25 06:31 Zer0 Voltage Note Edited: 0000231
2008-03-25 20:26 Kyle_Katarn Note Added: 0000232
2008-03-30 13:53 Orionizer Note Added: 0000236
2008-03-30 13:54 Orionizer Note Added: 0000237
2008-03-30 18:04 Kyle_Katarn Status feedback => acknowledged
2008-03-30 23:54 Zer0 Voltage Note Added: 0000242
2008-04-13 22:36 Zer0 Voltage Note Added: 0000305
2008-04-13 22:37 Zer0 Voltage File Added: SUMo-1.8-Vista-Loading.jpg
2008-04-13 22:37 Zer0 Voltage File Added: SUMo-1.8-Vista-Checking.jpg
2008-04-13 22:40 Zer0 Voltage Note Edited: 0000305
2008-04-13 22:51 Kyle_Katarn Status acknowledged => resolved
2008-04-13 22:51 Kyle_Katarn Fixed in Version => 2.8.1
2008-04-13 22:51 Kyle_Katarn Resolution open => fixed