View Issue Details

IDProjectCategoryView StatusLast Update
0000523SUMoBugpublic2008-03-24 17:35
ReporterZer0 VoltageAssigned ToKyle_Katarn 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.7 
Summary0000523: SUMo Doesn't Recognize Windows Installer Shortcuts (like those for Microsoft Office)
DescriptionI previously alluded to this in a post here:

http://www.kcsoftwares.com/forum/viewtopic.php?id=97

but have now confirmed it as a genuine issue and found the proper details you would need to fix it. ;)

Some programs use special "Windows Installer" (aka, "Advertised") shortcuts in the Start Menu that do not point to a drive/path and file like normal (aka, standard) program shortcuts do. Instead, they use special objects called descriptors to launch the programs.

If you bring up the properties for these special shortcuts and click on the Shortcut tab, the "Target location" and "Start in" fields are empty (at least in the ones I've seen) and the "Target" field is grayed out and [usually] filled in with the product name (instead of the drive, path, and file name). The "Find Target" and "Change Icon" buttons are also grayed out in such a case - as are any Advanced options - and the "Compatibility" tab is missing.

Full technical details about these special shortcuts are available here:

http://support.microsoft.com/kb/243630

and I also found some additional useful description info here:

http://www.zerog.com/InstallAnywhere.NET-3.1-User-Manual/Shortcuts_O.html

One common example of a program which uses these shortcuts is Microsoft Office (at least the 2003 and 2007 versions which use them for all of the individual Office components). Another freely available package which will create such a shortcut is Microsoft ActiveSync 4.5.

Needless to say, these special shortcuts obviously confuse SUMo and the associated programs do not get added to the list.

But since such shortcuts do represent valid installed programs, they really should be understood.

Thanks!
TagsNo tags attached.

Activities

Kyle_Katarn

2008-03-24 17:35

administrator   ~0000224

Was not so easy. Hopefully i found some good COTS ;-)

Issue History

Date Modified Username Field Change
2008-03-24 02:13 Zer0 Voltage New Issue
2008-03-24 10:18 Kyle_Katarn Assigned To => Kyle_Katarn
2008-03-24 10:18 Kyle_Katarn Status new => acknowledged
2008-03-24 17:35 Kyle_Katarn Status acknowledged => resolved
2008-03-24 17:35 Kyle_Katarn Fixed in Version => 2.8.1
2008-03-24 17:35 Kyle_Katarn Resolution open => fixed
2008-03-24 17:35 Kyle_Katarn Note Added: 0000224