View Issue Details

IDProjectCategoryView StatusLast Update
0000526SUMoNew Featurepublic2008-04-03 21:43
ReporterZer0 VoltageAssigned ToKyle_Katarn 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.8 
Summary0000526: Add Links to the Change Log, Known Issues, and Roadmap in the Help Menu or About Panel
DescriptionI think this would be very useful for advanced users (or even just plain curious ones). Plus this way people wouldn't need to hunt down those separate Mantis pages (which many users probably don't even know about).

The SUMo-only "Change Log" can apparently be linked to like this:

http://kcsofts.dyndns.org/mantis/changelog_page.php?project_id=11

and the SUMo-only "Known Issues" can be linked to like this:

http://kcsofts.dyndns.org/mantis/search.php?project_id=11&sticky_issues=on&sortby=last_updated&dir=DESC&hide_status_id=90

Though I guess you may want to call that "Known Issues and Feature Requests" to be fully descriptive. :)

You should probably verify I've gotten those links correct though. I'm not sure if Mantis would prefer something different. But those links do seem to work fine even if someone doesn't log in first and/or doesn't have pre-existing cookies for the site.

Of course, to add a Roadmap link, you would also need to actually create a roadmap entry first. ;) Perhaps the roadmap entries can just be stuff that you are absolutely certain you are planning to add at some point? If you don't have the time, any roadmap link can always just be added later too. Or you can forget about the roadmap and just go with the changelog and issues if you prefer.

There are two possible places for such links: in the help menu pull-down list itself or on the "About" panel. I suppose the About panel would be more appropriate since it already has button links there for the forum, web site, and e-mail. But then again, there isn't much room left there - so it would either need to be expanded or reformatted to fit more. Using the help menu pull-down list might be easier and even more logical, but in that case I would also then suggest moving those other About panel links there as well (just to stay consistent).

I was also thinking that perhaps the "?" could be changed to "Help". I realize this isn't exactly necessary, but more programs use "Help" than "?" - so using "Help" may be more recognizable to less experienced users. Not a big deal either way though. Just a matter of personal opinion. :)

Thanks!
TagsNo tags attached.

Activities

Zer0 Voltage

2008-03-30 23:38

reporter   ~0000241

I see this is marked for feedback. Was there something I need to add or comment on?

Kyle_Katarn

2008-04-01 20:55

administrator   ~0000254

My mistake, sorry

Zer0 Voltage

2008-04-01 21:43

reporter   ~0000260

No problem. Just wanted to be sure I didn't miss something. :) Thanks!

Issue History

Date Modified Username Field Change
2008-03-25 05:14 Zer0 Voltage New Issue
2008-03-25 20:26 Kyle_Katarn Assigned To => Kyle_Katarn
2008-03-25 20:26 Kyle_Katarn Status new => feedback
2008-03-30 23:38 Zer0 Voltage Note Added: 0000241
2008-04-01 20:55 Kyle_Katarn Note Added: 0000254
2008-04-01 20:55 Kyle_Katarn Status feedback => acknowledged
2008-04-01 21:43 Zer0 Voltage Note Added: 0000260
2008-04-03 21:43 Kyle_Katarn Status acknowledged => resolved
2008-04-03 21:43 Kyle_Katarn Fixed in Version => 2.8.1
2008-04-03 21:43 Kyle_Katarn Resolution open => fixed