View Issue Details

IDProjectCategoryView StatusLast Update
0000540SUMoNew Featurepublic2008-05-28 19:56
ReporterZer0 VoltageAssigned ToKyle_Katarn 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.9 
Summary0000540: Attempt to Reconnect on Network Failures During a Check and Support Resuming from the Point of any Check Failure
DescriptionRight now (as of version 1.7.0.42), if SUMo cannot connect to the version info server(s) while performing a check, we get a pop-up saying "Server Error. Please retry later."

Unfortunately, there are two big problems with how this is currently working: (1) It happens too quickly and without any retry attempt and (2) You must completely restart any check from the beginning afterwards.

With regards to the first problem, a stop actually happens immediately upon any connection failure. This means that even a slight momentary network problem will cause a SUMo check to completely abort. It would be far better if rather than immediately aborting it just [automatically] retried the connection attempt again for some set period of time or number of intervals. In fact, it would be even more useful if users had a way to set what that time interval or number of retries is (although there should be some logical preset default - not 0).

The reason this failure to retry connecting is so significant is that even heavy local network utilization can cause SUMo to fail. I tend to be doing so much that this happens almost 50% of the time. I am usually at least watching streaming video, but also often have some P2P session running. In such cases my router is usually overloaded, so SUMo thinks the connection isn't available when it really is - and SUMo would keep working if it just tried to reconnect for a while.

With regards to the second problem, having to completely restart from the beginning after a check failure is highly annoying if - like with me - there are hundreds of programs in the list. If SUMo aborts at 900-something out of 1000, I'd rather not have to start over again at 1. Instead, just have it pick up where it left off later once the network connection has been restored. This would be especially beneficial in cases where there truly is some [temporary] server connection issue.

Naturally, once you release the planned version with support for saving results, it should also save the point at which a check experiences any connection failure stop (or is manually stopped). That way users could also close SUMo and then start it again anytime later and resume a check from where it stopped.

Once this support is available, I would also suggest that in cases where a check has failed or been stopped the "Check" button should temporarily change to say "Resume" instead - and then later change back to "Check" once a successful check fully completes.

Feel free to break this into two separate feature requests if necessary. I wasn't sure if I should since these issues are directly related, but I also suppose you may need to implement separate updates for each issue at different times.

Thanks!
TagsNo tags attached.

Activities

Kyle_Katarn

2008-04-03 20:16

administrator   ~0000265

Very good idea and rich analysis.

This needs some studies on my side but this will certainly improve quality of service.

Zer0 Voltage

2008-04-05 01:28

reporter   ~0000277

Thanks, I try to be as detailed as possible when I report or request something. :)

Kyle_Katarn

2008-04-05 08:48

administrator   ~0000285

... and I appreciate it !

Kyle_Katarn

2008-05-26 23:43

administrator   ~0000331

Automatic retry (one) after 1 sec on any error

Zer0 Voltage

2008-05-28 06:40

reporter   ~0000333

Thanks very much for this update! Very helpful.

Any chance you would be able to make this a user controllable option in some future version?

I think it might be even more useful if there were settings options for both the number of retry attempts and the time-out value. Then users with network load issues can increase the values if necessary.

Perhaps you could add an "advanced settings" panel for settings like this - maybe for post-version 2.x low priority consideration?

Zer0 Voltage

2008-05-28 06:46

reporter   ~0000334

Oh, and there is still the "Resume" feature request in this. The retry update doesn't actually cover that. It would be nice to have SUMo save the check results in such a way that if there is a real connection failure SUMo can just pick up the check process later where it previously left off (rather than having to completely restart from the beginning). Thanks!

Kyle_Katarn

2008-05-28 19:56

administrator   ~0000337

Ok, i'll mark this one as "RESOLVED".

Please create a new demand for "Resume" which is much complex (but worth being implemented !)

Issue History

Date Modified Username Field Change
2008-04-03 05:29 Zer0 Voltage New Issue
2008-04-03 20:16 Kyle_Katarn Note Added: 0000265
2008-04-03 20:16 Kyle_Katarn Assigned To => Kyle_Katarn
2008-04-03 20:16 Kyle_Katarn Status new => acknowledged
2008-04-05 01:28 Zer0 Voltage Note Added: 0000277
2008-04-05 08:48 Kyle_Katarn Note Added: 0000285
2008-05-26 23:43 Kyle_Katarn Status acknowledged => resolved
2008-05-26 23:43 Kyle_Katarn Fixed in Version => 2.8.1
2008-05-26 23:43 Kyle_Katarn Resolution open => fixed
2008-05-26 23:43 Kyle_Katarn Note Added: 0000331
2008-05-28 06:40 Zer0 Voltage Status resolved => feedback
2008-05-28 06:40 Zer0 Voltage Resolution fixed => reopened
2008-05-28 06:40 Zer0 Voltage Note Added: 0000333
2008-05-28 06:46 Zer0 Voltage Note Added: 0000334
2008-05-28 19:56 Kyle_Katarn Note Added: 0000337
2008-05-28 19:56 Kyle_Katarn Status feedback => resolved
2008-05-28 19:56 Kyle_Katarn Resolution reopened => fixed