View Issue Details

IDProjectCategoryView StatusLast Update
0000544SUMoBugpublic2008-08-23 14:24
ReporterZer0 VoltageAssigned ToKyle_Katarn 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.8 
Target VersionFixed in Version2.3.1 
Summary0000544: Clicking on Cancel During the Startup Load Results in the Permanent Loss of the Entire Program List
DescriptionI'm really not sure what possible benefit there is to having a cancel button added to the "Loading..." pop-up window which appears on SUMo startup (as of the v1.8.0.43 beta). This had been requested here:

http://kcsofts.dyndns.org/mantis/view.php?id=533

but I cannot reopen that issue since I didn't create it.

Aside from lacking any apparent benefit (am I missing something?), the problem this has also now introduced is that clicking on Cancel while the list is loading results in a complete loss of the program list - even if you then exit and restart SUMo.

Imagine how that would make someone feel if they clicked cancel by accident or without having known this would happen? This really shouldn't get into any release code.

I also do not see any startup performance improvement as was alluded to here:

http://kcsofts.dyndns.org/mantis/view.php?id=524

The real problem, even for the person who requested the cancel button, is with SUMo taking much too long to start - not with needing to be able to abort the program list load.

A solution is desperately needed that will speed up the SUMo load time without risking any loss of the program list. The list load should actually be nearly instantaneous like with all competing solutions.

5-10 minutes to load a list of 726 entries is simply too long for any program regardless of what it does. I can't think of anything else which has ever loaded from a database so slowly. What is taking it so long?
TagsNo tags attached.

Relationships

child of 0000559 resolvedKyle_Katarn Automatically backup the app list 

Activities

Kyle_Katarn

2008-04-05 08:46

administrator   ~0000282

Permanent loss is a not desired side effect - will be fixed before official release.

Performance as mentionned in http://kcsofts.dyndns.org/mantis/view.php?id=524 will be improved in v1.9 (i did expect so many contribution for v1.8 ... you are TOO efficient ! ;-)

Kyle_Katarn

2008-04-05 21:43

administrator   ~0000292

Making it smarter (confirmation message) is getting tricky because of multithreading.
I'll live with it until performance matter is treated.

Load time is mainly due to the fact that, unlike most competitors SUMo extracts version info from executable themselves instead than simply reading the registry.

A nice workaround would be to assume that version didn't change since last execution of SUMo w/ a background update of version info

Zer0 Voltage

2008-04-10 04:21

reporter   ~0000298

Sorry, but I had to reopen this since the problem wasn't fixed in the v1.8.0.44 non-beta release. Clicking Cancel still causes everything to be lost - which is really bad.

Since the cancel button offers no benefit, it might be safer just to remove it if that behavior can't be fixed. It just runs too much of a risk for annoying users who lose their customized program lists.

At the very least, display some confirmation dialog stating that continuing to cancel will cause the loss of the program list (including any customization).

With regards to SUMo's slow startup being related to scanning the individual files, it was one of my original requests to offer an option not to do anything like that here:

http://kcsofts.dyndns.org/mantis/view.php?id=524

As I suggested there, you could have it do any file verifications during an actual network check. Scans and rescans are not an issue since they already do that anyway.

In other words, only have a file verification done [first] when the network check is done - like: check the local file, perform the network check, check the next local file, perform the next network check, and so on.

If done during the check like that, startup time would be faster (probably instantaneous) and check time probably wouldn't be any noticeably slower - though obviously that would need to be thoroughly tested first.

If something has been uninstalled since the last SUMo scan or check, just remove it from the list during the check and display the standard message about it when the check is done (just like after a scan).

If something has been upgraded since the last SUMo scan or check, just have the updated version info appear dynamically in the list window as the check is occurring.

I think anyone with an on-access antivirus program may be seeing much slower SUMo startup performance because of this. Not only is SUMo touching a large number of files, it may trigger any AV product each time it touches a file too.

At the very least, eliminating that file verification process on startup should be made an option for those of us with large numbers of programs in their list (so long as a local version check is still done before any network check that is).

Thanks!

Kyle_Katarn

2008-04-11 19:45

administrator   ~0000302

OK. Will be improved.

Issue History

Date Modified Username Field Change
2008-04-05 00:47 Zer0 Voltage New Issue
2008-04-05 08:46 Kyle_Katarn Note Added: 0000282
2008-04-05 08:46 Kyle_Katarn Assigned To => Kyle_Katarn
2008-04-05 08:46 Kyle_Katarn Status new => assigned
2008-04-05 21:43 Kyle_Katarn Status assigned => closed
2008-04-05 21:43 Kyle_Katarn Note Added: 0000292
2008-04-05 21:43 Kyle_Katarn Resolution open => not fixable
2008-04-10 04:21 Zer0 Voltage Status closed => feedback
2008-04-10 04:21 Zer0 Voltage Resolution not fixable => reopened
2008-04-10 04:21 Zer0 Voltage Note Added: 0000298
2008-04-11 19:45 Kyle_Katarn Note Added: 0000302
2008-05-26 23:31 Kyle_Katarn Relationship added child of 0000559
2008-08-23 14:24 Kyle_Katarn Status feedback => resolved
2008-08-23 14:24 Kyle_Katarn Fixed in Version => 2.8.1
2008-08-23 14:24 Kyle_Katarn Resolution reopened => fixed