View Issue Details

IDProjectCategoryView StatusLast Update
0000638SUMoNew Featurepublic2008-08-07 11:47
ReporterZer0 VoltageAssigned ToKyle_Katarn 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2.3 
Summary0000638: Improve Product Version Number Analysis
DescriptionRather than just looking at the file version property only, I think it would be useful to also check for a "Product Version" tag if the file version isn't found in the usual place.

When I tried to add the AT&T Pogo browser (Pogo.exe):

http://www.pogobrowser.com/

SUMo (2.0.0.50) displayed a pop-up which said:

"Executable is not supported (Version info is missing)"

When I looked at the Pogo.exe file properties, the file version (under the Version tab in the file properties panel) was 0.0.0.0 and the "File Version" tag value was "Personal" - so SUMo obviously isn't happy with one or both of those.

But the "Product Version" tag for the file shows 2.0.0.13 - and that is the proper version number for the product. So if SUMo recognized that tag, the file could be supported.

I realize this is an uncommon situation, but it would still be nice if it worked.

My suggestion, if possible, would be to first check for a version number in the file properties (1 in pogo-file_version.bmp). If not found there, or if something incompatible is found, then check the "File Version" item name tag (2 in pogo-file_version.bmp). And if nothing is found there either, or something there is also incompatible, or if that tag is missing, then check the "Product Version" item name tag (3 in pogo-product_version.bmp) if present. Only fail if nothing compatible is found in any of those places.

It would be important to check in that specific order, however, since I see cases where all three tags are present and each contains something different. You wouldn't want to use the "Product Version" item name tag value if the "File Version" item name tag value is present and valid - and you wouldn't want to use either of those if the file version property is present and valid.

Thanks!
TagsNo tags attached.

Activities

Kyle_Katarn

2008-07-26 23:13

administrator   ~0000383

Reminder sent to: Zer0 Voltage

Hi,

Would you please send me a zipped copy of Pogo's exe file ?
Email : kyle.katarn@kcoftwares.com

Regards,

Kyle

Zer0 Voltage

2008-07-30 01:00

reporter   ~0000386

File sent yesterday. If you didn't get it, check to see if it got filtered as spam. Attachments sent via Hotmail can get automatically flagged. :)

Zer0 Voltage

2008-07-30 04:56

reporter   ~0000387

BTW, I'm not just requesting specific support for AT&T Pogo only - I'm asking if SUMo can always check for the additional version number related item name tags [with all programs] if the main "File version" field ever isn't accepted for some reason. Thanks again!

Kyle_Katarn

2008-08-01 17:08

administrator   ~0000389

Please attach exe file for testing purpose

Zer0 Voltage

2008-08-02 00:59

reporter   ~0000392

So you didn't get the file I e-mailed you? The file is too big to attach here. Even compressed it's over 4 Meg. Try getting it from here instead:

http://www.fileflyer.com/view/v1oAeAG

Kyle_Katarn

2008-08-05 08:37

administrator   ~0000403

Unable to get the file from file-flyer.

Please contact me by email for a temporary FTP access.

Issue History

Date Modified Username Field Change
2008-07-26 12:41 Zer0 Voltage New Issue
2008-07-26 12:42 Zer0 Voltage File Added: pogo-file_version.bmp
2008-07-26 12:43 Zer0 Voltage File Added: pogo-product_version.bmp
2008-07-26 19:52 Kyle_Katarn Assigned To => Kyle_Katarn
2008-07-26 19:52 Kyle_Katarn Status new => acknowledged
2008-07-26 23:13 Kyle_Katarn Note Added: 0000383
2008-07-30 01:00 Zer0 Voltage Note Added: 0000386
2008-07-30 04:56 Zer0 Voltage Note Added: 0000387
2008-08-01 17:08 Kyle_Katarn Note Added: 0000389
2008-08-02 00:59 Zer0 Voltage Note Added: 0000392
2008-08-05 08:37 Kyle_Katarn Note Added: 0000403
2008-08-07 11:47 Kyle_Katarn Status acknowledged => resolved
2008-08-07 11:47 Kyle_Katarn Fixed in Version => 2.8.1
2008-08-07 11:47 Kyle_Katarn Resolution open => fixed
2011-04-13 19:12 Kyle_Katarn File Deleted: pogo-product_version.bmp
2011-04-13 19:12 Kyle_Katarn File Deleted: pogo-file_version.bmp