View Issue Details

IDProjectCategoryView StatusLast Update
0000643SUMoNew Featurepublic2011-01-29 01:24
ReporterZer0 VoltageAssigned ToKyle_Katarn 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2.12 
Summary0000643: Support Files Which Have a Version Number Tag But No Description (Name) Tag
DescriptionIn the uncommon case where the "Description" field is empty and no "Product Name" tag is present but a version number is available, allow the product to be added using the file name as the product name.

For an example of where this would help, see the attached file from EASEUS Partition Manager (the free "Home Edition" version):

http://www.partition-tool.com/

As you can see with that file, the "Description" field is empty and there is no "Product Name" item name tag - so if you try to add it to SUMo, you just get a popup saying the file could not be loaded.

But if you look at the file's properties, even though there is no name present the proper version number is present in the "File version" field and in both the "File Version" and "Product Version" item name tags.

So with this example, the product could be added showing "epm.exe" as the product name.

In the future, this would also tie into my previous request of allowing for users to rename or nickname products:

http://kcsofts.dyndns.org/mantis/view.php?id=520

Once that is implemented, users could use the nickname feature to display a real product name for any entries just using file names.

Also, does SUMo currently check for the "Product Name" item name tag if the "Description" field is blank? If not, I would also request that functionality be added too (similar to my recent request 0000638 of checking for additional version number item name tags with files that have no version number in the usual place).

Thanks!
TagsNo tags attached.

Activities

Kyle_Katarn

2008-08-01 17:19

administrator   ~0000390

In fact it was a bug in use of the "Internal Name" field as a backup

Zer0 Voltage

2008-08-02 01:06

reporter   ~0000393

Actually, the issue in the case of the file I attached isn't just which tag is used as a name backup - that epm.exe file doesn't have either a "Description" or a "Product Name" tag (just version tags).

Would it be possible to support files like this as well by using the file's name as the product name? I don't think the "Internal Name" tag could normally be used since that isn't always a logical name or the file name.

My other point was just that "Product Name" could be used as a backup when "Description" is invalid or blank, but this doesn't apply to a case like the file I attached where neither tag is available. Still, it's good if that is the case now. :)

Thanks again!

Zer0 Voltage

2008-08-03 21:51

reporter   ~0000396

I notice you created issue 0000648 to confirm that empty description and company fields are allowed as of v2.2.

But does this support cover all possibilities - like even if "Description" is blank _and_ both the "Product Name" and "Internal Name" tags aren't present?

If not, perhaps consider support for such cases as well - cases where no tags are present other than some version number tag. And then still allow it by using the literal file name ("whatever.ext") as the product name.

If that isn't also possible for some reason, feel free to just close or delete this issue.

Thanks again!

Kyle_Katarn

2008-08-05 08:34

administrator   ~0000401

0000648 was created because of a bug in v2.2.0 which allowed empty description AND empty company which led to a blank line in SUMo.

Kyle_Katarn

2008-08-05 08:34

administrator   ~0000402

OK

Kyle_Katarn

2009-12-22 19:43

administrator   ~0000561

Is bug still present in v2.7.0 ?

Kyle_Katarn

2009-12-27 01:18

administrator   ~0000565

Reminder sent to: Zer0 Voltage

Would you please give a look at this SUMo issue ?

Kyle_Katarn

2011-01-09 10:30

administrator   ~0000632

Still to be implementer -> Bitmeter2

Issue History

Date Modified Username Field Change
2008-07-30 05:31 Zer0 Voltage New Issue
2008-07-30 05:34 Zer0 Voltage File Added: epm.7z
2008-08-01 16:43 Kyle_Katarn Assigned To => Kyle_Katarn
2008-08-01 16:43 Kyle_Katarn Status new => acknowledged
2008-08-01 17:19 Kyle_Katarn Note Added: 0000390
2008-08-01 17:19 Kyle_Katarn Status acknowledged => resolved
2008-08-01 17:19 Kyle_Katarn Fixed in Version => Under Dev.
2008-08-01 17:19 Kyle_Katarn Resolution open => fixed
2008-08-02 01:06 Zer0 Voltage Note Added: 0000393
2008-08-02 01:06 Zer0 Voltage Status resolved => feedback
2008-08-02 01:06 Zer0 Voltage Resolution fixed => reopened
2008-08-03 21:51 Zer0 Voltage Note Added: 0000396
2008-08-05 08:34 Kyle_Katarn Note Added: 0000401
2008-08-05 08:34 Kyle_Katarn Note Added: 0000402
2008-08-05 08:34 Kyle_Katarn Status feedback => acknowledged
2009-12-22 19:43 Kyle_Katarn Note Added: 0000561
2009-12-27 01:18 Kyle_Katarn Note Added: 0000565
2011-01-09 10:30 Kyle_Katarn Note Added: 0000632
2011-01-29 01:24 Kyle_Katarn Status acknowledged => resolved
2011-01-29 01:24 Kyle_Katarn Fixed in Version 2.2 => 2.12
2011-01-29 01:24 Kyle_Katarn Resolution reopened => fixed
2011-04-13 19:12 Kyle_Katarn File Deleted: epm.7z