View Issue Details

IDProjectCategoryView StatusLast Update
0000708SUMoBugpublic2012-03-10 22:41
ReporterZer0 VoltageAssigned ToKyle_Katarn 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.3 
Target VersionFixed in Version3.0 
Summary0000708: Some Programs Not Being Handled Properly by SUMo 2.3.0.56
DescriptionStarting with version 2.3.0.56, there are two products (which were already in my list) no longer being properly handled:

1. Kyodai Mahjongg (kjm.exe) version 2006.0.0.108

2. System Information Analyzer (PC Wizard.exe) version 2008.1.8.5

SUMo still sees them and loads them into the list, but checks no longer work on them. The check does seem to try and analyze the files, but then almost immediately skips over them and moves on to the next entry.

Once the full check completes, these programs appear at the bottom of the list and have no graphic (check, star, or triangle) next to them and no text in the update column.

There's also no longer any data stored on the web pages, like this one for Kyodai Mahjongg:

http://kcsofts.dyndns.org/sumo/view.php?ProductName=Kyodai%20Mahjongg&Company=Rene-Gilles%20Deberdt

Naturally I thought it was the 4-number first digits in the version numbers - 2006 and 2008 - but that might not be the case since System Information for Windows (siw.exe) version 2008.7.15.0 still works fine.

I also didn't see anything obvious in the tags which would explain why the first two no longer work while the third one still does.

Files attached. Thanks!
TagsNo tags attached.

Relationships

child of 0000542 resolvedKyle_Katarn SUMo do not support version digits > 256 

Activities

Zer0 Voltage

2008-08-11 05:40

reporter   ~0000410

Mantis isn't letting me upload siw.exe. Hopefully you will not need that since it's the one which still works, but if you do end up needing it for comparison let me know and I'll upload it via FTP.

Kyle_Katarn

2008-08-11 09:47

administrator   ~0000411

I know this issue.
I've fonud a pretty workaround for 4-digits but this will require a complete re-design of the database....

Kyle_Katarn

2008-08-12 17:47

administrator   ~0000415

0000708: Some Programs Not Being Handled Properly by SUMo 2.3.0.56

I've also been having this issue with a couple of previously working applications:

Registry Repair Wizard (RCleaner.exe) [version: 2007.4.5.2]
http://kcsofts.dyndns.org/sumo/view.php?uid=34239645&ProductName=Registry%20Repair%20Wizard&Company=SmartPCTools

SymmTime (GeTTime.exe) [version: 2008.3.22.0]
http://kcsofts.dyndns.org/sumo/view.php?uid=34239645&ProductName=SymmTime%20Application&Company=

Good luck and thanks.

SeaKo

john5

2008-08-24 01:35

reporter   ~0000421

SUMo also has trouble with 0.0.0.* versions. SPORE Creature Creator, for example, is v0.0.0.1112, and it too isn't recognized.

Kyle_Katarn

2008-08-25 21:22

administrator   ~0000424

I confirm.... but such versionning convention is completely absurd ;)

Issue History

Date Modified Username Field Change
2008-08-11 05:28 Zer0 Voltage New Issue
2008-08-11 05:30 Zer0 Voltage File Added: kmj.exe
2008-08-11 05:30 Zer0 Voltage File Added: PC Wizard.exe
2008-08-11 05:40 Zer0 Voltage Note Added: 0000410
2008-08-11 09:47 Kyle_Katarn Note Added: 0000411
2008-08-11 09:47 Kyle_Katarn Assigned To => Kyle_Katarn
2008-08-11 09:47 Kyle_Katarn Status new => acknowledged
2008-08-12 17:47 Kyle_Katarn Note Added: 0000415
2008-08-22 08:30 Kyle_Katarn File Added: CropImage.png
2008-08-24 01:35 john5 Note Added: 0000421
2008-08-25 21:22 Kyle_Katarn Note Added: 0000424
2009-05-08 14:54 Kyle_Katarn Relationship added child of 0000542
2011-04-13 19:14 Kyle_Katarn File Deleted: kmj.exe
2011-04-13 19:14 Kyle_Katarn File Deleted: PC Wizard.exe
2011-04-13 19:14 Kyle_Katarn File Deleted: CropImage.png
2012-03-10 22:41 Kyle_Katarn Status acknowledged => resolved
2012-03-10 22:41 Kyle_Katarn Fixed in Version => 3.0
2012-03-10 22:41 Kyle_Katarn Resolution open => fixed