View Issue Details

IDProjectCategoryView StatusLast Update
0000809SUMoRefactoringpublic2013-11-15 21:15
ReporterKyle_KatarnAssigned ToKyle_Katarn 
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.3.4 
Target VersionFixed in Version3.7 
Summary0000809: SUMo loads too many times
DescriptionWhen I open SUMo, it loads 105 programs, which takes 4 minutes.

When I click "Check," it blanks out the listed programs and loads them again, which takes another 4 minutes.

Then it immediately blanks them out a second time and loads them a third time, which takes yet another 4 minutes.

Then, and only then, does it check them, which takes 50 seconds.

The programs obviously have to be loaded once, but why three times? Once they've been loaded, they should stay loaded. Clicking on
"Check" should result in SUMo immediately checking them. Is possible?
Tagsoptimization, UI, UX

Relationships

related to 0001642 resolvedKyle_Katarn Automation of Scan-Load-check operations 
related to 0001881 acknowledgedKyle_Katarn Indication of last scan / last check 

Activities

Kyle_Katarn

2009-06-09 11:59

administrator   ~0000534

Loaded twice in 1 second....

Info [09-06-09 12:00:47] Checking...
Info [09-06-09 12:00:47] Loading finished : 51 items loaded
Info [09-06-09 12:00:47] Creating database backup
Info [09-06-09 12:00:46] Loading...
Info [09-06-09 12:00:46] Preparing check operation
Info [09-06-09 12:00:46] Loading finished : 51 items loaded
Info [09-06-09 12:00:46] Creating database backup
Info [09-06-09 12:00:46] Loading...
Info [09-06-09 12:00:46] Scanning FFDShow Codec...
Info [09-06-09 12:00:46] Scanning XVid Codec...
Info [09-06-09 12:00:46] Scanning DivX Codec...
Info [09-06-09 12:00:46] Scanning Java...
Info [09-06-09 12:00:46] Scanning Shockwave...
Info [09-06-09 12:00:46] Scanning AIR...
Info [09-06-09 12:00:46] Scanning Flash...
Info [09-06-09 12:00:46] Scanning (light)...

Kyle_Katarn

2009-08-12 00:39

administrator   ~0000549

Have you unchecked the "reload before check" setting ?

godarts

2010-04-15 21:29

reporter   ~0000573

I have this trouble.
With unchecked button "reload before check" list loads 2 times. If button check - 3 times.

Kyle_Katarn

2010-04-15 21:50

administrator   ~0000576

OK, back to the top of the list. Will be fixed quickly.

Kyle_Katarn

2012-05-17 14:24

administrator   ~0000780

Does it still occurs with v3.0.7.153 ?

Kyle_Katarn

2012-05-20 14:20

administrator   ~0000796

http://www.kcsoftwares.com/forum/viewtopic.php?f=11&t=114&p=445#p445

poutnikg

2012-06-03 09:14

reporter   ~0000838

Just to add to have it explicitly stated even here:
Manual addition of file/folder should not need
the foreground GUI reload of the whole list.

poutnikg

2012-06-03 19:28

reporter   ~0000849

I think one automatic application list reload per session could be enough.

poutnikg

2012-06-19 08:18

reporter   ~0000887

All reloads following initial startup one
should be either explicitly requested by a user,
either advised but approved by user.

But former is better.
Or option to choose which variant.

dinovom

2012-07-12 19:44

reporter   ~0000942

Last edited: 2012-07-12 19:50

View 3 revisions

Another thing that would be nice: cancle button of loading (especially on startup) which was there but has been removed a view versions ago!!! I don't mind if database is lost then - if i cancle i do a full scan anyway afterwars so startup scan is completely useless!!!

Similar Bugs: http://www.kcsoftwares.com/bugs/view.php?id=533 http://www.kcsoftwares.com/bugs/view.php?id=1329

Removed cause of http://www.kcsoftwares.com/bugs/view.php?id=1581 http://www.kcsoftwares.com/bugs/view.php?id=1605 - sorry but then ppl shouldnt cancle??? You can make a warning that DB will be lost but dont remove it!!!

poutnikg

2012-07-23 07:56

reporter   ~0000990

Last edited: 2012-07-23 07:59

View 2 revisions

Are there problems in tracking of nature of the issue, e.g. reproducibility ?

Do you need other feedback aside of the forum provided log ?

It is very annoying behavior apps load being done twice before check,
if reload before check is set to OFF ( start up one and before check one).
Even 3 times - twice before check if set it ON.

poutnikg

2012-10-19 14:40

reporter   ~0001263

Is it not reproducible,is is hard to implement,
or just nobody is bothered by it but me ? :-D

SUMO starting - 1st load
SUMO Scanning - 2nd load
SUMO checking - 3rd load ( and optionally 4th load
                          if you insist on load before check )

I have about 320 applications and about 550 one before scan is filtered.
3 loads takes quite a lot of time.

As an option SUMO could work in optionally fully automated mode:

It would scan applications,
examine and filter the scan list
and check for the updates,
all in the single step, without even single button click of the user.

poutnikg

2012-10-19 14:56

reporter   ~0001264

Related to
http://www.kcsoftwares.com/bugs/view.php?id=1642

dinovom

2012-10-19 15:22

reporter   ~0001265

I guess it is reproducible (happens on all system i've installed it so far), i guess many ppl are bothered by it, it shouldn't be "hard" to implement (at least an option which checks to make) but sure it would take some time to implement (as you have to change/add parts in several places of code), as well as it has not that high priority (compared to bugs, some feature-lacks, ..).

poutnikg

2012-10-19 17:29

reporter   ~0001266

Last edited: 2012-10-19 17:32

View 3 revisions

I just ... this design flaw was reported 4 years ago, by author himself.. :-)

Also in April 2010 Kyle says it will be fixed quickly..

bytehead

2012-10-20 13:18

reporter   ~0001267

Last edited: 2012-10-20 13:18

View 2 revisions

For me and most people I know of, this is by far the most annoying aspect of current SUMo implementation. I think this issue should be given a much higher priority by Kyle, cause it seriously cripples user experience. There's no other as irritating bug as this one and it stands with no action for a too long time.

P.S. New features can wait... besides 0001642, of course :)

bytehead

2012-10-20 13:34

reporter   ~0001268

Last edited: 2012-10-20 13:47

View 5 revisions

I also noticed SUMo usually loads much faster on the immediate subsequent runs after the first one (on the scale of 6..15 sec down from 30..90sec for about 325 filtered apps). I guess this is due to local file system caching on the OS level, but may also be due to remote caching, too -- not figured yet whether it actually does remote polling at this stage, but I presume so.

Also, the duration of the very first "cold" loading is very diverse even under the same hardware/software configuration (30 - 90 sec for me, almost idle machine state).

Kyle_Katarn

2012-10-20 18:01

administrator   ~0001274

Hi,

I'm back. This issue is not my NUMBER ONE priority for next release.

Concerning 1st cold run being faster, i have to investigate in which extend to OS/HDD caching and how it cas be optimized by better processing by SUMo.

bytehead

2012-10-20 19:00

reporter   ~0001276

Kyle, I perfectly understand that your priorities as a developer are not always the same as regular users' priorities are -- you're trying to make a living here and we just want to make our lives/jobs a bit more convenient. But please do not underestimate usability issues, too -- for most users they are among the most significant if not the top ones. No software with serious UX issues can hope for a high popularity, despite all its other possibly coolest features. The reported issue at hand is exactly one of such problems. It annoys lots of users *every* time they use your software, which can't be good both for your business and reputation as a developer. Please get me right, I'm criticizing only because I want to help make it better: for you, myself and the whole SUMo community, current and future.

To recap: I'm not expecting it to be your #1 task for the next release, but please don't let it rust for years ;)

poutnikg

2013-04-08 17:58

reporter   ~0001415

Rusting... :-)

Tythesly

2013-04-16 20:19

reporter   ~0001416

ROFL... I thought it reloading a couple of times was normal XD

I do not have that bad of a problem though.... only 48 programs and its on my ssd.

poutnikg

2013-04-16 20:53

reporter   ~0001417

With hundreds on HD it can be very annoying, even irritating.

SUMO has plenty of updates addressing proper managing of particular software.
But I have occacional feelings that Kyle perhaps does not give enough attention to the program itself.

Kyle_Katarn

2013-04-16 21:40

administrator   ~0001418

... no I simply doesn't have much time these days !

That what it takes to be a developper during my free time and father of 2 cool daughters :)

poutnikg

2013-04-17 00:33

reporter   ~0001420

It is perfectly understandably, Kyle. :)
It is just thinking about distribution of time you can spend on SUMO.

Issue History

Date Modified Username Field Change
2008-09-28 10:13 Kyle_Katarn New Issue
2008-09-28 10:14 Kyle_Katarn Assigned To => Kyle_Katarn
2008-09-28 10:14 Kyle_Katarn Status new => feedback
2008-09-28 10:14 Kyle_Katarn Status feedback => acknowledged
2009-06-09 11:59 Kyle_Katarn Note Added: 0000534
2009-08-12 00:39 Kyle_Katarn Note Added: 0000549
2009-08-12 00:39 Kyle_Katarn Status acknowledged => feedback
2010-04-15 21:29 godarts Note Added: 0000573
2010-04-15 21:50 Kyle_Katarn Note Added: 0000576
2010-04-15 21:50 Kyle_Katarn Status feedback => assigned
2012-05-17 14:24 Kyle_Katarn Note Added: 0000780
2012-05-17 14:24 Kyle_Katarn Status assigned => feedback
2012-05-20 14:20 Kyle_Katarn Note Added: 0000796
2012-05-20 14:20 Kyle_Katarn Status feedback => assigned
2012-05-20 14:20 Kyle_Katarn Status assigned => acknowledged
2012-06-03 09:14 poutnikg Note Added: 0000838
2012-06-03 19:28 poutnikg Note Added: 0000849
2012-06-19 08:18 poutnikg Note Added: 0000887
2012-07-12 19:44 dinovom Note Added: 0000942
2012-07-12 19:47 dinovom Note Edited: 0000942 View Revisions
2012-07-12 19:50 dinovom Note Edited: 0000942 View Revisions
2012-07-23 07:56 poutnikg Note Added: 0000990
2012-07-23 07:59 poutnikg Note Edited: 0000990 View Revisions
2012-07-28 12:10 bytehead Tag Attached: UX
2012-10-19 14:40 poutnikg Note Added: 0001263
2012-10-19 14:41 poutnikg Tag Attached: optimization
2012-10-19 14:41 poutnikg Tag Attached: UI
2012-10-19 14:56 poutnikg Note Added: 0001264
2012-10-19 15:22 dinovom Note Added: 0001265
2012-10-19 17:29 poutnikg Note Added: 0001266
2012-10-19 17:29 poutnikg Note Edited: 0001266 View Revisions
2012-10-19 17:32 poutnikg Note Edited: 0001266 View Revisions
2012-10-20 12:58 bytehead Relationship added related to 0001642
2012-10-20 13:18 bytehead Note Added: 0001267
2012-10-20 13:18 bytehead Note Edited: 0001267 View Revisions
2012-10-20 13:34 bytehead Note Added: 0001268
2012-10-20 13:35 bytehead Note Edited: 0001268 View Revisions
2012-10-20 13:45 bytehead Note Edited: 0001268 View Revisions
2012-10-20 13:46 bytehead Note Edited: 0001268 View Revisions
2012-10-20 13:47 bytehead Note Edited: 0001268 View Revisions
2012-10-20 13:49 bytehead Priority normal => high
2012-10-20 13:49 bytehead Reproducibility have not tried => always
2012-10-20 18:01 Kyle_Katarn Note Added: 0001274
2012-10-20 18:01 Kyle_Katarn Priority high => immediate
2012-10-20 18:01 Kyle_Katarn Severity minor => major
2012-10-20 19:00 bytehead Note Added: 0001276
2012-12-29 19:15 Kyle_Katarn Relationship added related to 0001881
2013-04-08 17:58 poutnikg Note Added: 0001415
2013-04-16 20:19 Tythesly Note Added: 0001416
2013-04-16 20:53 poutnikg Note Added: 0001417
2013-04-16 21:40 Kyle_Katarn Note Added: 0001418
2013-04-17 00:33 poutnikg Note Added: 0001420
2013-06-09 13:47 Kyle_Katarn Status acknowledged => resolved
2013-06-09 13:47 Kyle_Katarn Fixed in Version => 3.7
2013-06-09 13:47 Kyle_Katarn Resolution open => fixed