View Issue Details

IDProjectCategoryView StatusLast Update
0002712SUMoNew Featurepublic2019-08-15 11:33
Reporterhydrurga Assigned ToKyle_Katarn  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.12.1 
Target Version5.9.6Fixed in Version5.9.6 
Summary0002712: HashTab Support
DescriptionHashTab support - see either HashTab32-5.2.0.14.dll or HashTab64-5.2.0.14.dll (attached) depending on installation
TagsNo tags attached.

Relationships

related to 0005578 feedbackKyle_Katarn Feature Request - Software I'd like to see SUMo monitor. 

Activities

hydrurga

2014-12-29 10:37

reporter  

HashTab.7z (492,635 bytes)

Kyle_Katarn

2016-06-26 21:19

administrator   ~0002436

Are these files in the sme folder as the main exe file ?

frank479

2019-07-25 09:14

reporter   ~0003605

I don't believe there is a .exe. It installs as a shell extension so I think the installer simply registers a dLL.

wolf

2019-07-25 17:57

reporter   ~0003607

I don't know this product resp. this shell extension. Frank already note in the related issue that this product has no file of type EXE. This makes sense as the shell which gets extended has its own main file which keeps in use. So I expect the same as Frank and Hydrurga, that this extension registers one or several libraries including the one attached by Hydrurga. These DLLs (32-bit and 64-bit) have file version info. As far as I understand, not the file version is relevant but instead the product version reported in file version info. Am I right?

And are these DLLs the only libraries installed or are other libraries installed too (i.e. with extension OCX)?

And to which file system folders did this extension install?
Did you also check the file system folders of the shell to extent and the systemdrive\Windows\WinSxS folders too which I consider candidate to some libraries too if not handled purely by Windows registration and registry?

Do you know if this shell extension uses .Net technology too?

I don't understand Kyles question neither. Sounds formulated a bit ambiguous without further context information. What do you mean by sme folder?
And what do you mean by main exe file for an extension?

Extensions usually don't replace the main file and function to extent but have to inform that main function of additional features of the extension instead. So the main function of the product to extent keeps in use and doesn't change. Its the runtime environment (especially internal tables) which gets extended by additional entries of the extension. It seems that there are misunderstandings and answering my questions will hopefully assist to clarify all parties involved to a common understanding.

frank479

2019-07-26 10:04

reporter   ~0003612

I believe the above DLLs are the only libraries installed. Nothing else (e.g. files suffixed with .OCX).

I think they were installed directly from C:\Program Files\Hash Tab Shell Extension where they currently reside now. Nothing was put in C:\Windows and/or its children folders.

The application didn't mention any requirements (e.g. .Net) other than Vista or greater. Didn't see anything on their website either.

I think "sme" means "same". And I think back then he assumed it had an .exe to accompany the dLL but we've since clarified that matter since it attaches itself into the Windows Properties tab of a right-clicked file and functions within it with no additional .exe.

Regarding your very first question, the author advertises the file as version 6.0.0.34. And, if you go inside P&F and check the listing, in the Name field it states HashTab 6.0.0.34. And that same version is also listed next to it in the actual version field. However, if you do Windows Properties->Details on the file, it shows the Product Version as 6.0.0.0 (not .34) and the File version as 2.1.0.0. Not sure what the difference is between a File and a Product and an actual version but, I'm sure he does. Hopefully, those discrepancies won't trip up SUMo.

Kyle_Katarn

2019-07-26 10:13

administrator   ~0003613

OK so, what is expected is :

To add
C:\Program Files\Hash Tab Shell Extension\HashTab32*.dll
C:\Program Files\Hash Tab Shell Extension\HashTab64*.dll
and in both case to use the version from the file name and NOT the one from Product or File version info

Correct ?

frank479

2019-07-26 10:18

reporter   ~0003614

Yes. I think that's correct at least for now. You never know what the author might do in the future.

frank479

2019-07-26 10:20

reporter   ~0003615

And in the P&F, it did list the correct version in the version field. So, if you can read that field, use that instead of trying to extract it from the name.

wolf

2019-07-26 17:24

reporter   ~0003616

Yeah, with the current design of SUMo, the proposed solution of note https://www.kcsoftwares.com/bugs/view.php?id=2712#c3613 seems the best one considered acceptable also by note https://www.kcsoftwares.com/bugs/view.php?id=2712#c3614 .

The product version field in the file version info seems only the 2nd best alternative as it should be the same and is reported as different. So with this alternative, major updates shall get detected while minor updates may keep undetected.

Note https://www.kcsoftwares.com/bugs/view.php?id=2712#c3615 would require some redesign of SUMo. It comes of installer resp. uninstaller. In order to give such redesign a direction, SUMo needs some internal and hierarchical version definition and annotation of possible sources distinguishing between distribution level, bundle level, product level, component level and file level and hopefully to be published in an own design document or FAQ. If these sources of version information would be published at the same time or later is a policy decision as current SUMo design doesn't yet use all these sources. And open source projects reveal that you always find software publishers with different usage and assignment of version info (or none at all). I like the Debian project strategy of assigning version info if the software publisher doesn't use one or to support two independant version schemes of different sources. And there exist software tools which only use installers and uninstallers for version info, ignoring the other options like files and components.

Kyle_Katarn

2019-07-27 16:02

administrator   ~0003625

OK @frank479, i'll look for P&F instead.

Issue History

Date Modified Username Field Change
2014-12-29 10:37 hydrurga New Issue
2014-12-29 10:37 hydrurga File Added: HashTab.7z
2014-12-29 11:24 Kyle_Katarn Status new => acknowledged
2015-06-21 15:32 Kyle_Katarn Target Version => 4.0
2015-07-05 11:31 Kyle_Katarn Target Version 4.0 => Short term
2016-06-26 21:19 Kyle_Katarn Note Added: 0002436
2016-06-26 21:19 Kyle_Katarn Assigned To => Kyle_Katarn
2016-06-26 21:19 Kyle_Katarn Status acknowledged => feedback
2019-07-24 21:51 Kyle_Katarn Relationship added related to 0005578
2019-07-25 09:14 frank479 Note Added: 0003605
2019-07-25 17:57 wolf Note Added: 0003607
2019-07-26 10:04 frank479 Note Added: 0003612
2019-07-26 10:13 Kyle_Katarn Note Added: 0003613
2019-07-26 10:13 Kyle_Katarn Target Version Short term => 5.9.x
2019-07-26 10:18 frank479 Note Added: 0003614
2019-07-26 10:20 frank479 Note Added: 0003615
2019-07-26 16:43 Kyle_Katarn Status feedback => confirmed
2019-07-26 17:24 wolf Note Added: 0003616
2019-07-27 16:02 Kyle_Katarn Note Added: 0003625
2019-07-27 16:02 Kyle_Katarn Target Version 5.9.x => 5.9.6
2019-08-15 11:33 Kyle_Katarn Status confirmed => resolved
2019-08-15 11:33 Kyle_Katarn Resolution open => fixed
2019-08-15 11:33 Kyle_Katarn Fixed in Version => 5.9.6