View Issue Details

IDProjectCategoryView StatusLast Update
0005445SUMoNew Featurepublic2019-11-10 17:37
Reporterwolf Assigned ToKyle_Katarn  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version5.8.12 
Target Version5.10Fixed in Version5.10 
Summary0005445: extent logging to multi-session
DescriptionSUMO does reporting and logging. But logging is currently limited to a session. Multi-session logging is not yet supported. This makes it harder to do trend analysis. So please extent logging to cover more sessions. The number of sessions should not be hard coded but might be implicit. Such an implicit limit might become configurable by providing configuration options to specify these limits in days and in size.

It's then not a good idea to replace a multi-session log by a new one and delete the current one. Replacement should happen at the event level according to a kind of LILO (last in last out) strategy. By this I mean that when reaching the time limit, those entries before the past interval may be deleted and when reaching the size limit the oldest entries shall be deleted (either the oldest entry replaced by the new one or deleting all entries of the oldest day on entry of a new one).

When SUMO is running in background after finishing scanning, checking and reporting, there seem only to be some kind of keep alive messages between SUMO client and server. Those keep alive logs may be deleted on session end for multi-session logging unless there is a problem in this link to the server, i.e. due to server maintenance tasks.

Consider storing an intermediate log update not on closure but on end of reporting.
TagsNo tags attached.

Relationships

related to 0005749 assignedKyle_Katarn DUMo extent logging to multi-session 

Activities

Kyle_Katarn

2019-10-13 11:03

administrator   ~0003734

Done for significant errors only useful for reliability / robustness trend monitoring.
Displayed in exportable log in debug mode only.

Issue History

Date Modified Username Field Change
2019-04-23 21:59 wolf New Issue
2019-04-23 23:23 Kyle_Katarn Assigned To => Kyle_Katarn
2019-04-23 23:23 Kyle_Katarn Status new => acknowledged
2019-04-23 23:24 Kyle_Katarn Target Version => Short term
2019-10-13 11:02 Kyle_Katarn Target Version Short term => 5.10
2019-10-13 11:03 Kyle_Katarn Status acknowledged => resolved
2019-10-13 11:03 Kyle_Katarn Resolution open => fixed
2019-10-13 11:03 Kyle_Katarn Fixed in Version => 5.10
2019-10-13 11:03 Kyle_Katarn Note Added: 0003734
2019-11-10 17:37 Kyle_Katarn Issue cloned: 0005749
2019-11-10 17:37 Kyle_Katarn Relationship added related to 0005749