View Issue Details

IDProjectCategoryView StatusLast Update
0005495SUMoBugpublic2019-06-26 00:33
ReporterwolfAssigned ToKyle_Katarn 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.9.1 
Target Version5.9.4Fixed in Version5.9.4 
Summary0005495: SUMo starting with incomplete status text line
DescriptionWhen SUMo starts, it is loading the report of already detected software tools and their update state according to last check if scanning and checking has been performed in a previous run of SUMo. But the status text line isn't complete missing one summary section usually displayed after checking. How do I need to configure SUMo to show a complete status line without requesting a new check by SUMo?
Steps To ReproduceIf SUMo has never performed a scan nor a check, intitiate these actions and look at the status line in the resulting report seeing also the summary of available update counts (major + minor count). Then close SUMo.
Make sure having automatic scanning and automatic checking on startup of SUMo disabled in order to speedup time for restarting SUMo.
The restart SUMo again. It loads the report according to last scan and check operation with sort order as for the scan operation, not the check operation. (Default order of SUMo report on loading on startup being the same as after last check operation is preferred. But changing that order after display is finished to get this prefered sort order.) Look at the status line and see that the summary section of the last check operation is missing as shown in attached screenshot.
TagsNo tags attached.

Activities

wolf

2019-05-22 21:31

reporter  

sumo.status.20190522.png (289,410 bytes)

Kyle_Katarn

2019-05-22 21:34

administrator   ~0003372

Vey nice bug :-)
In this case status is from local cache, and some information may be innacurate. Would you expect the same information as if information would come from a "check" (consistent with symbols) OR a specific message (eg : "loaded from cache, please check") ?

wolf

2019-05-22 22:35

reporter   ~0003376

Yes, I expect the same information as coming of a check operation.

What do you mean by inaccurate?

Do you mean outdated or falsified due to some side-effect of caching?

Possibly outdated is expected. Otherwise a new check operation has to be performed. But I did disable automatic check operation due to long duration (about 14 minutes on speedy Intel Atom processor with lot of RAM and half the number of products installed as on more powerful CPU with much more RAM and also more installed products still taking about 6-9 minutes.)

Such an alternative warning might be helpful for users not knowing what they configured. I don't want it there in the status line.

If you want provide a choice to users, then you may make it configurable and put such a message there if the user wants such a kind of verbose reporting. Then SUMo would implement different kinds of verbose behaviour (log file, status line, popup windows).

Kyle_Katarn

2019-05-27 22:09

administrator   ~0003398

You're finally right : since cache has a very short TTL we should expect the same GUI behavior. I'll fix accordingly.

Issue History

Date Modified Username Field Change
2019-05-22 21:31 wolf New Issue
2019-05-22 21:32 wolf File Added: sumo.status.20190522.png
2019-05-22 21:33 Kyle_Katarn Target Version => 5.9.2
2019-05-22 21:34 Kyle_Katarn Assigned To => Kyle_Katarn
2019-05-22 21:34 Kyle_Katarn Status new => feedback
2019-05-22 21:34 Kyle_Katarn Note Added: 0003372
2019-05-22 22:35 wolf Note Added: 0003376
2019-05-23 16:21 wolf Issue cloned: 0005502
2019-05-23 16:21 wolf Relationship added related to 0005502
2019-05-27 22:09 Kyle_Katarn Note Added: 0003398
2019-05-27 22:09 Kyle_Katarn Status feedback => acknowledged
2019-05-30 15:01 Kyle_Katarn Target Version 5.9.2 => 5.9.3
2019-05-31 09:25 Kyle_Katarn Target Version 5.9.3 => 5.9.4
2019-06-26 00:33 Kyle_Katarn Relationship deleted related to 0005502
2019-06-26 00:33 Kyle_Katarn Status acknowledged => resolved
2019-06-26 00:33 Kyle_Katarn Resolution open => fixed
2019-06-26 00:33 Kyle_Katarn Fixed in Version => 5.9.4