View Issue Details

IDProjectCategoryView StatusLast Update
0005502SUMoBugpublic2019-06-26 00:33
ReporterwolfAssigned ToKyle_Katarn 
PrioritylowSeverityminorReproducibilityhave not tried
Status acknowledgedResolutionopen 
PlatformOSWindows 10OS Version1809 64-bit
Product Version5.9.1 
Target Version5.9.xFixed in Version 
Summary0005502: SUMo starting with incomplete report after loss of Pro license
DescriptionWhen SUMo Pro looses its registered license, a new start of SUMo will lead to unexpected behaviour. Loss of license doesn't affect the SUMo database of locally detected software tools, including their version information. But what happens with SUMo knowledge of last check of update availability while having valid license?

When starting SUMo after loss of license, it pops up a window of invalid license. I've a time-limited license which has not yet expired. Invalid and expired mean two different things to me. Does SUMo consider them synonym?

When starting SUMo again after this strange popup window closed, it didn't reappear as license state didn't change and the head of its display became returned to base mode as expected. It also reloaded the set of software tools detected in its last scan before loss of license. But instead of loading also the state of these tools of the last check operation, the last standard column labeled Update remained EMPTY although expecting the values of last check operation. And such expected behaviour is what happens when registration state of SUMo didn't change (for so whatever valid or invalid reason).
Additional InformationI couldn't find any SUMo user documentation what leads to loss of registered SUMo Pro license. It happened to me already the 2nd time within two weeks. I got an answer to the first event. But the 2nd seems to be random with only vague assumption related to client/server communication in certain rare situations. It's on the KC Softwares watch list now.

I don't know if the behaviour of SUMo is the same when instead of loss of license the license expires. I assume my license still valid for several months, just needing to reenter the license claimed invalid. And the work-around for missing values of last check operation is to check again.

But I can't see a need nor a reason why SUMo should forget this kind of information with the change of its registration state!
TagsNo tags attached.

Relationships

related to 0005508 feedbackKyle_Katarn SUMo starting with incomplete report 

Activities

Kyle_Katarn

2019-05-27 21:58

administrator   ~0003395

I'll also add "persistent multi-session" log file in order to help troubleshooting this issue.
Looks like it's liked to loss of communication with licence server (trapping defensive logics)

Issue History

Date Modified Username Field Change
2019-05-23 16:21 wolf New Issue
2019-05-23 16:21 wolf Issue generated from: 0005495
2019-05-23 16:21 wolf Relationship added related to 0005495
2019-05-25 14:46 wolf Issue cloned: 0005508
2019-05-25 14:46 wolf Relationship added related to 0005508
2019-05-27 21:57 Kyle_Katarn Target Version => 5.9.x
2019-05-27 21:58 Kyle_Katarn Assigned To => Kyle_Katarn
2019-05-27 21:58 Kyle_Katarn Status new => acknowledged
2019-05-27 21:58 Kyle_Katarn Note Added: 0003395
2019-06-26 00:33 Kyle_Katarn Relationship deleted related to 0005495