View Issue Details

IDProjectCategoryView StatusLast Update
0005549HDDExpertBugpublic2019-06-22 03:17
Reporterwolf Assigned ToKyle_Katarn  
PrioritynormalSeverityminorReproducibilityalways
Status feedbackResolutionreopened 
PlatformOSWindows 10 64-bitOS Version1809
Product Version1.18.3 
Target VersionFixed in Version 
Summary0005549: too primitive behaviour of Spare button
DescriptionWhen I click on the Spare button in the middle, a tab in the standard web browser opens with a result page for hard disks in Amazon. Why?
Why does this query not take into account the size of the existing storage?
Why does this query not take into account the existing interfaces for storage attachement of my computer?
Why does this action not initiate a guided dialogue to prepare a kind of lookup?
Why does this action not take into account any eventually established procurement procedures or preferred suppliers?
Why are new storage devices of smaller size considered appropriate spare parts?
Why are hard disks with rotating disks considered spare parts for PCIe SDD?
(The query in Amazon may report only internal or external hard disks with rotating disks of various form factors with attachemend via SATA, IDE/PATA, FibreChannel, SAS, USB, FireWire, Serial or Ethernet. So attachements via DIMM or PCIe are not considered suitable!)
And why may acquisition of cloud storage not be acceptable neither?
Additional InformationPlease take into account already existing attachement options of existing computer, size of existing device, eventual existing procurement procedures and eventual existing preferred (resp. mandated) suppliers before launching an Internet look up.
TagsNo tags attached.

Activities

Kyle_Katarn

2019-06-21 21:11

administrator   ~0003490

This is intentionnal at this stage of the design : simple redirect to Amazon with simple request. May be made more accurate / complex at a later point in time if a more specific partner is found.

wolf

2019-06-22 03:17

reporter   ~0003494

I disagree. You didn't answer any of my questions on this reported bug. There is no manual or help information reporting such limitations. Also product page doesn't report of such limitations why a rotating internal hard disk is considered an acceptable spare part for a M.2 SDD (PCIe) device on a tablet without any space for such an internal hard disk with rotating disks. And it has nothing to do with any partner. Whenever a dummy request is posted such engines will produce an correspondingly dummy reply. So the bug is not with this partner but with HDDExpert instead.

If you don't want to invest more in the query, you'll probably get a better answer if you consider the existing device as an acceptable spare part. You've a button on the left side which will query Google for the device detected. So you might put this query onto Amazon to get better reply by Amazon. Just a better quick fix.

I can't remember getting a good deal proposed by Amazon for hard disks while it may happen for some special requirements on SDD. I'm sending my research to special search engines allowing better control. My preferred one for IT components is based in Austria but covers several countries of Europe. But this search engine isn't suitable for most embedded devices nor larger servers.

And why don't you want to split this bug report for such a quick fix and a long term redesign?
These questions are independant of partnership. They may result in better search requests whatever partner you have. And eventually you have users wanting to pay you for getting a professional version of HDDExpert which allows customization in their corporate purchasing process with their preferred suppliers list.
Such proposed dialogues are intended to clarify the decision process what may be an acceptable spare part option to the user taking into account limitations and options of the existing computing device.

And I haven't seen a long term redesign on the roadmap for this tool neither yet.

Issue History

Date Modified Username Field Change
2019-06-21 01:53 wolf New Issue
2019-06-21 21:11 Kyle_Katarn Assigned To => Kyle_Katarn
2019-06-21 21:11 Kyle_Katarn Status new => closed
2019-06-21 21:11 Kyle_Katarn Resolution open => no change required
2019-06-21 21:11 Kyle_Katarn Note Added: 0003490
2019-06-22 03:17 wolf Status closed => feedback
2019-06-22 03:17 wolf Resolution no change required => reopened
2019-06-22 03:17 wolf Note Added: 0003494