View Issue Details

IDProjectCategoryView StatusLast Update
0000556SUMoNew Featurepublic2019-05-19 20:22
ReporterZer0 VoltageAssigned ToKyle_Katarn 
PrioritynormalSeverityminorReproducibilityN/A
Status acknowledgedResolutionreopened 
Product Version 
Target Version5.9.xFixed in Version 
Summary0000556: Remove the Loading, Checking, and Scanning Pop-Up Windows
DescriptionI originally posted this in a note under a separate issue, but figured I should move it here as a stand-alone new feature request instead.

Those mini pop-up windows are fairly annoying because they take over focus - which means you cannot move or resize the SUMo window until a load, check, or scan completes.

Perhaps a better solution would be to do without any pop-up windows and rely on the status and progress bars to do their jobs alone.

In fact, just updating the Check and Scan buttons would be more efficient (or at least non-redundant) in those cases. So instead of a "Checking..." or "Scanning..." pop-up window the Check and Scan buttons can just temporarily change to "Cancel" or "Stop" until the respective operation completes (then change back). That way the program window wouldn't get locked out and no functionality would be lost.

In such a case, you could also update the text used in the status bar to reflect the current action in more detail - like "Currently performing a normal scan... ({X:\Path\...})", "Currently performing an in-depth scan... ({X:\Path\})", and "Check in progress... (X/Y)". Appropriate text is already there for program list loads.

Thanks!
TagsNo tags attached.

Relationships

related to 0004045 confirmedKyle_Katarn Ability to completely disable extra windows - Use only the main interface 
related to 0005485 acknowledgedKyle_Katarn "Blocking action" feature still not documented after more than 11 years now 

Activities

Kyle_Katarn

2008-04-16 20:40

administrator   ~0000308

I'd prefer not as "modal" windows are the best and most efficient protection against side effects.

Maybe would you like more "real time" info displayed ?

Zer0 Voltage

2008-04-17 21:39

reporter   ~0000310

No, it's not an issue of real time info. That's already there. My problem is with the stolen focus and inability to move or resize the SUMo window when those pop-ups are open. The load, scan, and check processes can take very long to complete and the SUMo window is stuck in place until they finish - making it difficult to monitor the progress and also open other programs while waiting. Plus it may be harder to have SUMo run as a true background process if it needs to use pop-ups (and I assume that's probably a long term goal). What sort of side effects do they protect against?

Kyle_Katarn

2008-04-17 21:49

administrator   ~0000311

If you don't put "modal" pop-up you have to prevent user to launch any new "blocking" action... and to restore everything once processing's done.

It led me to many bugs on previous projects...

Zer0 Voltage

2008-04-28 05:28

reporter   ~0000318

I'm not sure what you mean by blocking action or what gets restored, but I would still like to request a way to do things without such popups since I often need to resize the program window when some function is processing and would eventually like to be able to run SUMo as a background process (though I suppose that should be a post-2.0 concern). Thanks!

Kyle_Katarn

2008-04-28 19:51

administrator   ~0000319

OK !

avmaksimov

2008-09-28 20:29

reporter   ~0000447

I think that it is not so actual, there are other tasks for implementation. It is possible and suffer a little, after all almost all processes occupy no more than two-five minutes. If would be it is more, would be much more actual!!!

wolf

2019-05-11 15:31

reporter   ~0003270

Any progess in the mean time?

What's the state of operation of SUMo without GUI, especially as with version 5.9 SUMo Online has been added which should work even when a remote device has SUMo installed although not started with a GUI while initiating an operation request on the new dashboard?

(I didn't verify as not all devices monitored in my dashboard are located in the same room.)

And disabling / enabling of auto-focus may be in interesting feature also to prepare for taking screenshots for support requests on certain race conditions.

Kyle_Katarn

2019-05-12 12:11

administrator   ~0003281

Still not implemented, but this would now make more sense !

Issue History

Date Modified Username Field Change
2008-04-14 00:43 Zer0 Voltage New Issue
2008-04-16 20:40 Kyle_Katarn Status new => closed
2008-04-16 20:40 Kyle_Katarn Note Added: 0000308
2008-04-16 20:40 Kyle_Katarn Resolution open => won't fix
2008-04-17 21:39 Zer0 Voltage Status closed => feedback
2008-04-17 21:39 Zer0 Voltage Resolution won't fix => reopened
2008-04-17 21:39 Zer0 Voltage Note Added: 0000310
2008-04-17 21:49 Kyle_Katarn Note Added: 0000311
2008-04-28 05:28 Zer0 Voltage Note Added: 0000318
2008-04-28 19:51 Kyle_Katarn Note Added: 0000319
2008-09-28 20:29 avmaksimov Note Added: 0000447
2009-04-12 11:58 Kyle_Katarn Status feedback => assigned
2009-04-12 11:58 Kyle_Katarn Assigned To => Kyle_Katarn
2009-04-12 12:01 Kyle_Katarn Status assigned => feedback
2016-09-24 22:13 Kyle_Katarn Relationship added related to 0004045
2017-01-22 21:44 Kyle_Katarn Status feedback => acknowledged
2017-01-22 21:44 Kyle_Katarn Target Version => Long term
2019-05-11 15:31 wolf Note Added: 0003270
2019-05-12 12:11 Kyle_Katarn Note Added: 0003281
2019-05-12 12:11 Kyle_Katarn Target Version Long term => 5.9.x
2019-05-16 09:24 wolf Issue cloned: 0005485
2019-05-19 20:22 Kyle_Katarn Relationship added related to 0005485