View Issue Details

IDProjectCategoryView StatusLast Update
0005770SUMoBugpublic2019-11-29 22:08
Reporterwolf Assigned ToKyle_Katarn  
PrioritynormalSeverityminorReproducibilitysometimes
Status feedbackResolutionopen 
PlatformOSWindows 10 (x64)OS Version1903
Product Version5.10.3 
Target VersionFixed in Version 
Summary0005770: SUMo Pro update (sometimes) dysfunctional
DescriptionAt least since version 5.10.2, I observe that SUMo Pro update function gets dysfunctional.

I've configured it intentionally to do a lookup on SUMo server. My standard web browser is the latest released version of Firefox, no beta version. Usually, when I initiate a single update regardless for which tool reported out of date by SUMo, it opens a new tab in my standard web browser. When it doesn't work, it does nothing. It doesn't change anything on the usually already started standard web browser, regardless if web browser is minimized or opened window on desktop. When SUMo Pro update function gets dysfunctional, it remains so.

A restart of SUMo doesn't help. It doesn't change that behaviour.

Sometimes, a restart of the standard web browser may help. Sometimes, a restart of the standard web browser has no effect.

As far as I remember, I experience that symptom at least since the Windows updates of October 2019.

The desired feature to lookup SUMo server is still available and working at these times. It is possible to start a new tab in the standard web browser manually and enter the URL for SUMo server monitor and enter the product name it that search mask. It's only the correspondingly configured update function of SUMo Pro remains without action in such a case.

So don't know the reason nor how to make that determenistic nor the work around to become deterministic.
Additional InformationThe same problem applies also sporadically to Intel Driver and Support Assistant.
TagsNo tags attached.

Activities

Kyle_Katarn

2019-11-28 21:02

administrator   ~0003788

Why would this come from SUMo, in particular if Intel Driver and Support Assistant is affected too ?
Any other user facing the same issue ?

wolf

2019-11-28 22:26

reporter   ~0003791

I guess that there is some dynamic runtime dependency, that this runtime gets modified by some hidden events, and that these two applications don't sufficiently check their dependencies. Not sure if that symptom may relate to changes in Windows or in Firefox and if they require other runtime changes simultaneously.

Si if SUMo doesn't check its runtime dependencies sufficiently, I consider it a bug in SUMo, regardless of the reason of less known or undocumented changes in runtime context. Wanted to report that change in behaviour and see if other users made similar observations and eventually got that behaviour deterministic already. So analysis isn't finished and don't know to which extent other users have made same observations and further analysis already.

Kyle_Katarn

2019-11-29 22:08

administrator   ~0003792

OK. I keep it in "Feedback", as being monitored.

Issue History

Date Modified Username Field Change
2019-11-28 17:00 wolf New Issue
2019-11-28 21:02 Kyle_Katarn Assigned To => Kyle_Katarn
2019-11-28 21:02 Kyle_Katarn Status new => acknowledged
2019-11-28 21:02 Kyle_Katarn Note Added: 0003788
2019-11-28 21:02 Kyle_Katarn Status acknowledged => feedback
2019-11-28 22:26 wolf Note Added: 0003791
2019-11-29 22:08 Kyle_Katarn Note Added: 0003792