View Issue Details

IDProjectCategoryView StatusLast Update
0006004Startup SentinelBugpublic2021-03-22 21:49
Reporterwolf Assigned ToKyle_Katarn  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.7.7 
Fixed in Version1.8.1 
Summary0006004: export to CSV files is faulty, resulting in too few lines displayed
DescriptionWhen using the export to CSV file feature is used, no CSV file will be stored, as in various other KC Softwares tools. Instead of creating a CSV file, Startup Sentinel launches the standard application for displaying CSV files with a content resembling the records reported by Startup Sentinel but fewer lines. The reason for fewer lines displayed is a merge. Several of the records displayed in Startup Sentinel get merged to a single line in the standard application. The standard application gets launched by Startup Sentinel. The (most) standard application opens the import filter. When using the tab as field separator in the import filter (most reliable for most widely used CSV files) I get a display of records consisting of just one field. When using the semi-colon as filed separator in the import filter, I get a display of records consisting of three fields but fewer lines as reported by Startup Sentinel as the resulting 3rd field displayed seems to include further records displayed by Startup Sentinel although no such field separator was in such records. This seems to happen especially with long records reported in Startup Sentinel.
Tagsexport

Relationships

related to 0006003 resolvedKyle_Katarn export to text file results in too many lines displayed and no text file stored 

Activities

Kyle_Katarn

2020-04-29 07:03

administrator   ~0003908

Duplicate of 0006003 ?

wolf

2020-04-29 12:25

reporter   ~0003909

No, it's no duplicate. There are similarities due to same data source (same reported data to export). But the export format is different and the effects with the same data source are different. When exporting to CSV, the result displays too few lines as records get merged (ID 0006003). Here, when export to text, the result is the opposite that too many lines get displayed as line breaks seem to get inserted.

As long as I don't try with a different standard application, I can't know which part is responsible for that effect. My guess is that such an effect is the result of a design error in Startup Sentinel but that the line breaks I assume inserted by the standard standard application for text files. Trying to repeat with a different standard application may reveal if my assumption is correct. Not to launch the standard application would remove such a dependency and solve it on the side of Startup Sentinel if my assumption gets confirmed. I recommend not to launch a standard application by default. You might want to make this behaviour configurable for users preferring the comfort of automatic launch. And when rendering it configurable, you may want to provide another option if the launch should be without user interaction as is the case currently or with the standard Windows dialog which would preselect the standard application but propose some alternative applications too (difference between one-click and double-click in Windows opening dialogs).

Kyle_Katarn

2020-05-30 09:41

administrator   ~0003945

More details about the missing content please ?

Issue History

Date Modified Username Field Change
2020-04-29 03:48 wolf New Issue
2020-04-29 03:48 wolf Issue generated from: 0006002
2020-04-29 03:50 wolf Tag Attached: export
2020-04-29 07:03 Kyle_Katarn Assigned To => Kyle_Katarn
2020-04-29 07:03 Kyle_Katarn Status new => feedback
2020-04-29 07:03 Kyle_Katarn Note Added: 0003908
2020-04-29 12:25 wolf Note Added: 0003909
2020-04-29 12:28 Kyle_Katarn Status feedback => acknowledged
2020-05-30 09:41 Kyle_Katarn Status acknowledged => feedback
2020-05-30 09:41 Kyle_Katarn Note Added: 0003945
2021-03-22 21:43 Kyle_Katarn Relationship added related to 0006003
2021-03-22 21:49 Kyle_Katarn Status feedback => resolved
2021-03-22 21:49 Kyle_Katarn Resolution open => fixed
2021-03-22 21:49 Kyle_Katarn Fixed in Version => 1.8.1