View Issue Details

IDProjectCategoryView StatusLast Update
0006012SUMo ServerNew Featurepublic2020-05-12 21:25
Reportervikaesar Assigned ToKyle_Katarn  
PrioritynormalSeverityminorReproducibilityalways
Status acknowledgedResolutionreopened 
PlatformWindows 
Product Version5.10.17 
Summary0006012: Directory Opus beta release automatic detection
DescriptionDirectory Opus (64-bit) is a well-known file manager for Windows systems.

https://www.kcsoftwares.com/sumo/view.php?prot=2&ProductName=Directory+Opus+%2864+bits%29&Company=GP+Software

It has a version numbering scheme (X.Y.Z.f) that would simplify a lot detecting new beta releases and thus avoiding false positives for new stable updates in SUMo:
- A stable update always follows this pattern: X.Y.0.0 (Ex. 12.19.0.0 > 12.20.0.0)
  * Paid (major) upgrades change X version number component
  * Free (major) updates change Y version number component
- A beta update changes only the Z version number component (Ex. 12.20.0.0 > 12.20.2.0)
- A custom minor fix would change the last (f) version number component (Ex. 11.9.0.0 > 11.9.0.1)

This would allow SUMo to know if an update is a stable or beta release just by looking at the version number. Easy-peasy.
Steps To ReproduceJust performing a scan when a new update is released for Directory Opus shows this behavior.
Tagsautomation

Activities

vikaesar

2020-05-12 11:09

reporter   ~0003926

Status has changed to resolved but automatic detection is not working.

Kyle_Katarn

2020-05-12 21:25

administrator   ~0003927

Yes, it was only because of manual fix.
I keep it open.

Issue History

Date Modified Username Field Change
2020-05-08 15:02 vikaesar New Issue
2020-05-08 15:02 vikaesar Tag Attached: automation
2020-05-08 15:20 Kyle_Katarn Assigned To => Kyle_Katarn
2020-05-08 15:20 Kyle_Katarn Status new => resolved
2020-05-08 15:20 Kyle_Katarn Resolution open => fixed
2020-05-08 15:20 Kyle_Katarn Project SUMo => SUMo Server
2020-05-12 11:09 vikaesar Status resolved => feedback
2020-05-12 11:09 vikaesar Resolution fixed => reopened
2020-05-12 11:09 vikaesar Note Added: 0003926
2020-05-12 21:25 Kyle_Katarn Status feedback => acknowledged
2020-05-12 21:25 Kyle_Katarn Note Added: 0003927